Automation Behavior Inconsistencies - vst2 and vst3

On testing the new beta release this morning, (Win 10, AL 11 Suite), I noticed a difference between how the automation behaves on stopping playback of presets that have macros in them.

In vst3, any track automation remains live (enabled) upon stopping playback which is what I expected it to do (and doesn’t in the current version). But in vst2, although the automation remains enabled, the automation parameter on the track jumps to macro 2 every time on playback.

1 Like

thanks paul

will take a look at this

1 Like

Hi @Paul881

I can’t replicate that behaviour

could you possibly provide a video or sure fire way to replicate the problem

Hi @bryan_spence,

I can’t now either. Very strange. Although if I try to automate one of the macros or one of the macro parameters on a preset with macros engaged, it greys out on stopping playback but as Phil says, I think it is supposed to do that?

Hi Paul

I cannot re-produce that either, could you possibly show a video or screen grab of this?

Hi @bryan_spence ,

Here is a screen grab. Hope it helps. The top instance of ANA 2 is vst2 and the second one is vst3. Both instances grey out automation of macro upon stopping playback. Let me know if you need anything else. Happy to have a zoom call if it helps.

Hi guys :wink:

@Paul881 Maybe uploading your ANA 2 preset could help Bryan to troubleshoot this further.

If you could start from the Menu/ Init preset and manage to replicate the initial issue with VST2, save your preset and then reload it to test the behavior with VST3, then upload the preset here on the forums.

But again, might be tricky with Ableton, as mentioned before in another topic, as soon as Live received any parameters change for an existing automation, that automation will be disabled and the indicator will turn grey on Live’s GUI. So the trick is to be able to narrow down what exactly is sending a Midi or parameter change to Live.

if you can provide me the ALS project file that might help.

I’m trying a few more things here to try and reproduce.

Hi @bryan_spence

Here is the dropbox .als file which I hope works for you. I will do the other testing that you have suggested when I get back later today.

Dropbox - File Deleted



Here’s the preset:

Here’s the screen grab:

I disconnected my USB keyboard just to make sure it wasnt sending any spurious messages but you can see that as soon as I hit stop on playback, the automation greys out both on vst2 and vst3.

Let me know if you need anything else.



i can’t reproduce this still even with this project file

at this point i think its possible that you have some MIDI Learn Assigned to your spacebar (presumably you use that to stop start? )

Try right clicking your Filter master in ana and check to see if there is any MIDI learn assigned and then remove it.

also try stop starting with the stop button up top

If I use the stop button, the vst2 version greys out but the vst3 version doesn’t. The vst3 version doent grey out even if I use the space bar to start/stop. There is no midi learn associated with the filter cutoff in ANA.


Following up on this one, have you installed latest ANA 2 stable release v2.0.98 and check if you’re still having the same issue with this version ?