Ableton Loop Cycle PROBLEM!


This has been a problem with every version of live: When you take a perfectly trimmed clip, say a drum beat, and loop it, there is often a glitch at the top of the loop when it cycles back around.
so to speak also when i put audio one shots (for example a bassdrum) into the arrangement and make an one bar loop it always looses the impact on the very first beat when it cycles around !! that is sooooo annoying !!! i dont know what to do it really pisses me off
In other programs, when you loop the sample, there is no glitch, so it's not inherent in the sample. 

Please help me

do you mean when you drop them into the arrange window as audio files ?

I have had some experience with kick loops from the Dom Kane pack where the loop misses the Click of the first kick every time it cycles but never from loops i’ve made myself. Those same loops work perfectly in logic pro, Reason and Pro Tools.

I found two ways to deal with this in Ableton

First was to copy and paste the clip and not drag it out.

Second was to put the loop in simpler and re trigger every time.

Thats intersting because when I drag and drop a drum look I had the same problem - I thought it was just me - but as Jon said copy and paste or put in simpler

It’s not a problem I’ve ever encountered myself, but have you tried adjusting the Fades in arrange view? Pull the first one right back, that might help give it a bit more punch?

hey thanks guys for the quick replys…

yeah i found out that i dont have that issue when i work with midi - but always have it when i work with audio.

thats aweful !!

it is so that it misses the initial click at the start of the sample and lacks therefore the punch i want !! beats 2,3,4 are so as it is supposed to be but always have the problem on beat one when the loopcycle goes round !

i mean that can not be the solution to make fades ?

i logic pro 9 it works perfectly - but in live 8.1.5 i still have those problems !

i hate that ! it ruins really my workflow and is often so that i will quit a session because it ruins my complete vibe

Try upgrading your version of Ableton also if that does not work I’d post on the Ableton forums

I don’t have Ableton in front of me right now, but I’m pretty sure it’s fading the clip start/end, which should be a default action.

Try going to:

Edit > Preferences > Record Warp Launch >

Then turn off ‘Create Fades on Clip Edges’. You should be able to toggle it back on in the Clip view.

That said, I’m not quite sure why you’d want to loop a 1-shot. If you’re dealing with just drums, why not load them into a Drum rack, program the midi and treat them as 1-shots? That way, you can control the ADSR amp envelope to suit the track.

Hope that helps.

i still struggle with some nasty glitches and clicks … i am frustrated !!

now i have read on the ableton forum that this is really a common problem in live 8 !

but i have following thoughts - would be super cool if some of u can give me tipps about that …

yesterday i rendered a shaker loop (wav) from ableton out in 96khz 32 bit - i wanted to try processing it in logic studio with the stereo spread tool but the wav file did not even work in there !!

so i had a search and i found out that the sampling rate does not fit with the logic settings. so i bounced the stuff out of ableton in 44.1 khz 16 bit and so it worked now also in logic !

my question is could it be that because of i use 96khz in ableton that this is the thing that makes this glitches and clicks ?

i mean it can not be my iMac i7 with 8 GB of Ram … this must be a setting fault …

also i saw that i have in my focusrite saffire settings only the 44.1 khz settings activated. now i have 96khz in ableton. could that also be a problem ?

what should i do and try and what samplerates and bitdepths are u using !!! ??



44.1 is certainly the standard cross platform, so worth trying.

There is likely no perceivable benefit in using 96Khz, and will only cause problems further down then line - ie when it has to be converted back to 44.1 anyway.