ANA 2 Presets piano issues - part 2

Hi, I am following the videos in HTMH Part 2 & whenever I try to load the ANA 2 preset piano into audio it automatically switches it to MIDI which means it doesn’t play as a piano in audio. I’ve re-watched the relevant part of the video numerous times - he does refer to it as a MIDI but you can see it plays in audio, so I know it’s the Ableton software not doing what it should! Please advise, thanks

1 Like

Welcome aboard on the forums ! :sunglasses:

Sorry, not clear to me what course you’re following, could you please post a link or course/video title ?

ANA 2 is a Plugin Instrument, you can only load it on a MIDI track inside your DAW.

The MIDI Track in your DAW outputs the audio signal to your master by default, thus you should have sound & audio when you press the ANA 2 virtual keyboard on the plugin interface or if you create a MIDI CLIP on this track.

Hi, sorry no this is the ANA 2 PRESET available in the assets folder of Ableton from the How to Make House Music Part 2 programme. Then I load the piano from the presets folder as directed on the video. Course title is How to Make House Music with P-LASK & part 2 videos 4 or 5 is the one I’m referring to. Thanks for your help.

Thanks for your reply and clarifying :wink:

  • Those .SndPr files in the Assets folder are presets for ANA 2, you can only open them with the plugin.

  • If you haven’t already demo ANA 2, you should be able to use the Demo Version, you can find this on the product page here : ANA 2 Product page there’s a “Try ANA” link to get the demo.

Once you’ve got ANA 2 installed, you can load it on a MIDI track inside Ableton.

Then click on MENU and choose LOAD PRESET and navigate to your folder where the .SndPr files are located to load the preset inside ANA 2.

See screenshots below.

Hope this helps ! :wink:

Screenshot 2024-05-02 at 15.27.07

Screenshot 2024-05-02 at 15.29.55

Hi, thanks for your help with this - I am downloading the demo right now. The other issue is, and apologies that I wasn’t clear on this (I have only just gone through it this eve to review the issue) - the issue I am having is under the assets folder - MIDI - Instruments - Piano_EbM7_Gm7.mid when I try to load this as per the video instructions it loads as MIDI (which I understand because it’s a MIDI :slight_smile: ) but on the video it stays as audio and there is sound whereas when I do it there is no sound!

Checked back the video here and seems that would be in Tutorial 05 - Piano Chords at 01:35 time frame.

So P-Lask is actually dragging this Piano_EbM7_Gm7.mid ( which is a MIDI CLIP ) onto a MIDI Intsrument Track that already has an instance of ANA 2 on it :wink:

So there’s 3 things you need to do to get the same sound, but ANA 2 is required anyway ( again, try to install a Demo version ).

1 - After Installing ANA 2 demo ** : create a new MIDI track and load an instance of ANA 2 on it.

2 - To get the same sound, you 1st need to load the preset inside ANA 2 from the Assets Folder ( from the saved folder on your computer, not the link inside Ableton after adding the Folder ).

3 - Then Drag & Drop the Piano_EbM7_Gm7.mid MIDI CLIP onto the ANA 2 Instrument MIDI track.

I’ve recorded a video showing this, you can download or watch it from this Dropbox link.

Hope this helps !

Cheers :sunglasses:

This is brilliant, I can totally see exactly what I need to do, thank you for this! However :frowning: when I download that demo (and other demo plug-ins) e.g. ANA2 v2.5 it installs it but then only shows the manual plus some other text docs. Where is the plug-in? How do I get it from the downloaded folder into Ableton? I have tried to drag & drop various bits into the plug-in folder but I presume this is not the way to do it? Any more help greatly appreciated.

It’s ok, I’VE DONE IT!! Thank you so much. It came down to me not having the VST2 settings on in Live. Thank you so much again :slight_smile:

1 Like

Cool ! :sunglasses: Happy to read that you’ve got it sorted on your end :+1:

You can also enable VST3 plugin format inside Ableton Live Settings/Preferences → Plug-Ins

Reason for this is that some Plug-Ins manufacturers have dropped VST2 support, so if they just provide VST3, you need to have this enable inside Live as well :wink:

On a more general note about dealing with Plug-ins inside Live, you can check this Blog Article :wink:

1 Like