ANA2.5 - question about Multisamples directory

First of all, thanks for adding the Multisampling feature!

So I updated ANA to 2.5 and finding myself a bit confused about how and where to add directories for Multisamples.
I don’t have the Multisamples Expansion, which I’m guessing would probably make things clearer. I’d buy it but unfortunately I’m pretty much broke these days, so… nada lol.

Now I wanted to add some Multisamples on my own, and I’m just not sure how to set this up right from the start, in order to keep things organized.
To make more obvious what I mean some screenshots:
First one is from a video by Protoculture about the 2.5 update

You can see he’s got a “Multisamples” category under Sampler Osc.

I don’t have this category

Tried to add this by creating folders, for example

Tested with several naming variations and also under the User sub directory, but it simply doesn’t show up in ANA.

This particular thing also isn’t mentioned in the updated manual for ANA 2.5.
Will those categories be created whilst the importing of Multisamples? This whole thing probably isn’t a biggie, but I’d really like to know that before creating my own Multisamples for ANA.
Because when it comes to organizing content ANA can be a bit… awkward. At least to me.


there are a couple included multisamples with the update - their presets are accessible from the main preset browser

their individual sample files and patch are located in
ANA 2 > Waves > DLC > Sampler Osc > Multisamples

If you create a multisample patch and save it down it will go to your User location
ANA 2 > Waves > User > Sampler Osc > Multisample > General

re: this section above - those title columns are clickable / changeable to whatever section you want


Jesus, I can’t believe that I haven’t noticed this lol. After you said it I seemed to remember that I knew this once, but obviously I forgot about that.
This is helpful already.

Initially I wanted to ask now about possibilities to create a subfolder structure for Multisamples.
But this seems to be redundant for the moment, because I’m encountering a far more basic issue.

I did some tests with creating Multis, but ANA can’t find the samples afterwards.

A very basic example with only 5 Multisamples from a Moog:

Even though the samples are stored in two locations I’m getting that error. And there doesn’t seem to be a function that would “re-link”, “re-find” or any other way I could tell ANA where the samples are.

I made screenshots of what I did before as well (they might have been useful for what I wanted to ask initially)

Imported the samples with saving to a new folder “test”

Saved the Multisample to a new folder “test” as well

So, to me it seems I’ve done everything correctly (?)
But after closing and reopening ANA can’t find the samples. This happened not only once, btw.

(Windows 10, latest version of ANA, in case it matters)

can you send me the MSPr

Here it is, thanks for responding so quickly!
I’m running out of time at the moment, so I probably won’t be able to answer for quite some time, maybe not even today anymore.
(just for info purpose)

test-funk.MSPr (3.3 KB)

where were the samples located before you dragged them in? (drag and drop?)

In this case I was using drag n drop from my E:\ drive.
That’s not an external (USB) drive. It’s directly connected to the mainboard.

But it already happened when dragging from the C:/ drive as well. And if I’m not mistaken also when importing via Browser/Explorer.

In most cases I was using ANA as a “pseudo”-standalone running it in a VST host (nanoHost by Tone2).
But also happens when running ANA inside Bitwig for example.

Had time for some little additional tests, out of curiosity.

With the “test-funk” example I did everything with the vst 2 version of ANA so far, importing/creating samples, saving multi and testing afterwards. Wanted to know if the vst 3 version would find the samples, but that’s not the case.
Don’t know if it would make any sense/difference if I created the exact same thing with the vst 3 version, probably not (?)

I was also curious if “Run as Administrator” (the respective host) could solve the issue. “ProgramData” is an even hidden system folder per default, so it might be the case that this issue could be a file permission thing. Wanted to know if ANA can see the samples when running the host as admin.

Tested with four hosts, nanoHost again, Bitwig Studio, GigPerformer and Nektarine (plugin-host that comes with MIDI-Keyboards/Controllers by Nektar, similar to NI KompleteKontrol)

No difference, same error as always.

Other than that I’m leaving everything “as is” now.
Had a look if there’s a beta version for ANA that I might have tested, but it says “Beta Version Coming Soon”.

More testing…

Purpose was to find out if it makes a difference WHERE the samples are coming from and HOW they are imported.
Try to sum up properly what I did, to make it short:
I made several (slightly renamed) copies of those 5 Moog “Funk” samples and placed them to different locations on the computer. One set to the E: drive, two sets to the D: drive (internal HDD, just like E:), and two sets to the C: drive.

  • Started with creating a .MSPr using the “Import” function with samples from the E: drive (since I was already using dragndrop from E: with the original test-funk example)
  • Then I created two more .MSPr with samples from D:, one time using dragndrop, one time using “Import”
  • Same procedure with samples from C:

In all cases I was using the vst2 version of ANA as a pseudo-standalone (nanHost).
In all cases I imported the samples with “add new folder”.
In all cases I saved the Multisample with “add new folder” and “Import the samples used to your User Library?” ticked.
In all cases I checked the results with vst2 and vst3 versions of ANA.

ANA can’t find a single sample afterwards. “5 samples missing” allover the place.

It doesn’t make any difference WHERE the samples are coming from and HOW they are imported.

That’s… not good.

Thought about doing this test with an entirely different set of samples. But I’m not really motivated to spend another hour or two, only to confirm something’s not working.
I finally found some time to make use of this new feature, and now I can’t do anything with it because it’s… well, not working. All I do is testing and posting a monologue.

That’s… not good.

will test this out today - what version of windows are you running

1 Like

My OS isn’t becoming younger with the years but I can’t really upgrade the version, and I’m not having any trouble with it so I don’t feel the need to upgrade anyway.

I’m on Windows 10 Enterprise 2016 LTSB Build 14393.5717 (1607/RS1)

I’m attaching the 5 samples as well, in case you’d need them.


EDIT: can’t attach because of the file size limit, this is more or less a direct download link for the .zip

did the computer explode, @bryan_spence ?

apologies, have been a bit tied up with our new plugin.

checking it out now

ok i can confirm i can reproduce this bug - if you do not check the “Import samples used to the user library” option when saving the MSPr for the first time it should function as normal?

Thank you.

I can confirm when “Import samples used to the user library” is not checked everything’s fine and no errors occur when recalling the MSPr later.
It also doesn’t seem to matter if “Do you want to copy samples to user folder? (recommended)” when importing samples is answered Yes or No. So basically every time when samples are saved to C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Sampler Osc\Multisample it leads to the “samples missing” error afterwards.

Another little thing I noticed:
whenever samples have been imported via dragndrop it leads to this:

The root notes displayed at the bottom are reversed.
C1 is C5 (bottom), C2 is C4 (bottom) and so on. This is probably only a graphical glitch and has nothing to do with functionality. It’s ALWAYS the case when samples were dragndropped, and NEVER the case when samples were imported via file-browser.


Let me guess:
no rival for ANA, so no Synth.
no effects plugin (unless it would be a multi-fx plugin, with a variety of effects, then maybe).

I’d think it could be a Drum Machine.
Or, and that’s my favorite for the moment: some kind of MIDI-Arp-Sequencer-Chord plugin. An Arpeggiator/Sequencer combined with the CMD Device. Something like that (???)

I have a workaround for ANA’s lack of creating a subfolder structure for Multis on its’ own.

Per default it’s only possible to import and to save to one parent folder.


When creating a whole bunch of Multis this behaviour would sooner or later lead to either very clustered and messy parent folders, or an immense list of parent folders.

I’m using this workaround for now:
The saved Multisample (.MSPr) can be moved to any folder afterwards, and ANA is able to detect those without problems.
So a folder structure for .MSPr can be achieved fairly easy, and could look like this then:

Creating something like that for the imported samples requires more effort, but can be done.
When moving the samples to different folders after creation of a Multi, ANA won’t be able to find the samples anymore when opening the .MSPr afterwards. This can be fixed by editing the .MSPr file.
It contains the path for the sample files. When opening the file with i.e. Notepad++ it will look like this:

This can be modified, in order to tell ANA where to find the samples:

That’s a bit of an additional effort, but to me it’s worth it because it results in an organized Multisample library:

Of course this is still only a workaround, so that would be a feature request, to make this easier.

As far I can see it would only require the ability to set subfolder paths when importing and saving, not only one parent directory.
Then this entire workaround would be implemented per default, I guess (?)

did the new plugin explode, @bryan_spence ?
hope you’re not hurt.

sorry i have been on leave for a few days.
We’ve identified the issue so it will be rectified in our next release :+1:

1 Like