Cubase 8 overloading cpu

I’ve been following Bjorn Akesson’s uplifting trance course (really great), but I’m finding near the end that my cpu is overloading, causing the DAW to freeze and stutter.

Does anyone know whether it’s most likely to be my laptop configuration, or the way I’m using Cubase (maybe not using instruments efficiently or something)?

I’m using Cubase 8.1, Asus laptop Intel Core i5 2.7GHz with 8MB RAM.

I’m working round it by freezing and unfreezing tracks but it’s a pain as it’s time-consuming.

Cheers if anyone can give any tips.


Are you using any sound card?

Or have you tried the “asio for all” driver if you are using internal on mowed sound?

Thanks, Phil

I use a Focusrite Scarlett 2i4 external sound device, connected by USB through a USB 3.0 data hub.

What buffer setting are you using?

Thanks. It seems to be set on the maximum in the Focusrite control panel - 10ms

The lower the latency the higher the CPU. Try some other settings see if it improves things.

Thanks, I’ll play around with that.
Cheers again