DAW rendered-out kick drum WAV does not sound exactly like the Kick2 "generated" kick drum ..?

(I seem to be the only person who has questions on this forum !) ; )

Anyway, here goes another one…

I am rendering out from my DAW a kick drum made in Kick2, in WAV format.
It renders out OK, but when I re-import it and check it against the original kick drum made in Kick2, its is very slightly different.
The Kick2 kick drum has a slightly more noticeable attack. Its slight but noticeable.

However, if I use the generate feature in Kick2, it produces an exact replica.
I’m using region render in Reaper.

I’m using a midi note to trigger Kick2. Keytrack is off, velocity is off. etc.
The image below is the generated one in kick2 (A) the one to the right (C) is the DAW rendered one.
(I know one is stereo (B - the Kick2 generated one)… mono is the same result.)

The best way to get your Kick to an audio file is to render it from KICK 2.

So first click on “Render” and then “Generate” and once the waveform appears you can either export it as a wav file on your computer or simply drag & drop the waveform onto an empty audio track in your DAW.

The rendered kick will always be stereo, you can convert it to mono later on if needed, either using your DAW ( if available ) or using an audio editor software.

If you notice that the attack of the rendered kick is slightly different ( like it seems to be the case here ) then make sure that your DAW is not automatically adding fades at the beginning / end of audio files, I don’t know about Reaper but in Live this is a default option that you need to deactivate.

1 Like

thanks, yes, I checked Reaper for fades and turned them off.

My complication is that I have numerous tracks all with Kick 2 on them and they are going through an extra EQ etc. on my mixbus, which makes choosing ‘generate’ within Kick2 more tricky, because those generated in Kick2 would not have the mixbus sauce applied to them.

But actually , what I found in the last 5 minutes is that I was exporting Mono 96kHz files, and Kick 2 was in Stereo mode.
I was comparing my exported WAV Mono kick to Kick 2’s stereo kick.
I just tried exporting as Stereo from my DAW, and the exported stereo kick now compares well with the kick sounding out in Kick 2 !

Funny how my exported mono kick is noticeably lacking the attack that the stereo one has. My DAW project is 96kHz.
Should converting down to mono from stereo really affect it that much?

Now, I’m going to export in stereo and find a way of converting to mono so it doesn’t lose that attack.

Actually, just for future readers who might have a similar problem, I think with Reaper, 2nd pass rendering did make a difference too:

You are over complicating things IMHO, unless you absolutely want to build full loops or tracks from your KICK 2 instances sound design and apply effects on those tracks to sculpt your sound, why not simply render your KICK 2 sounds and either use them as source sounds either in a sampler or as audio files and then apply your effects ?

Not only it’s much more easy to compare your Kick 2 rendered files with Kick 2 playback but it also will save you DSP and CPU resources since you won’t be using several plugins instances.

So for info, KICK 2 render and export will always be in STEREO, the Mono/Stereo option in the settings affect the way Kick 2 is processing audio on the fly but not the render, so setting Kick 2 to Mono can help to save some CPU but that’s it, rendered Kicks will always be stereo files.

What’s the use of such a high sampling rate ?

You’re dealing with percussive sounds and likely electronic music ( tho I have no clue of the genre of music or project you’re dealing with of course :wink: ) and you probably don’t need such a high sampling rate. By default Kick 2 is set to output and render at 16bit / 44100 which is enough, it will save you DSP and CPU as well. Keep in mind that depending of your computer and audio interface specs, higher sampling rate will demand more resources and could create audio artifacts as well.

Again, Kick 2 is rendering in Stereo only ( I’m talking about Kick 2 render & export itself, not the track render option available from the DAW, Reaper allows you to render to Mono Stems ).

Now there shouldn’t be any difference between a Mono and a Stereo file except for slight perceived loudness and imaging ( but our ears won’t pick this if both channels of a stereo sound are identical ) and that’s what it is, a stereo audio file from a mono source is nothing else but the same signal split onto 2 channels with each channel volume ( intensity ) divided by 2 : our ears will perceive the same centered sound with the same intensity as the Mono file ).

You can see this on the waveform of default Kick 2 sound rendered ( using Track Rendering from Reaper ) in Mono and Stereo. It’s the same waveform, with the same attack, just 2 channels with their volume /2 for the stereo file, but they add and we end up with the same output.

Check those Simple Sines as well for Mono VS Stereo ( right click for the “Save Audio as” option ).



So all in all, it’s a question of workflow as well as Reaper settings ( like the automatic fades previously mentioned ) but Kick 2 should render to audio what you hear when playing back Midi, now if your DAW, DSP and CPU are working harder, you may get some artifacts, especially on the 1st Midi note trigger playback, it’s often the case in many DAWS, your very 1st kick might have a slightly different attack and you may end up with this difference if you record Kick 2 track output onto another channel or bounce the track to audio, best thing is to use a loop and not a single shot playback then and get rid of any kick shot loosing it’s attack.

I’m not that familiar with Reaper to be honest, seems that there’s a lot of options available for audio playback, sampling rate and rendering tracks to audio, but again if your generate and export your Kick using KICK 2 built in export, you’ll get a stereo file and your attack should remain the same. Then make sure that Reaper doesn’t apply any fades when importing the audio file back.

1 Like

thanks, appreciate the verbose reply.
Why does Kick2 choose to generate in stereo, if the sound is the same? Generating a mono file will surely save in terms of file-size. A mono file is half the size of a stereo file.

By default Kick 2 is set to output and render at 16bit / 44100 which is enough

And are you saying that exporting from Reaper at 96 kHz is redundant since Kick 2’s maximum internal sample rate is 44.1 kHz ?

From what I know it is by design, don’t forget that you can pan your clicks when making a Kick as well as inverting channels phase, so it gives more options to work with stereo. Not sure what’s taking place at the rendering stage, but a conversion to Mono might not be the best way to do I suppose ( but again, that’s a development thing, not sure about everything involved behind the hood here :wink: ).

Not exactly :wink: You can render at a higher rate than the “default” 44.1 kHz if you wish, so if your Reaper Project settings is 96 kHz then you can Render → Generate → Export to audio and you’ll get a 16bit 96 kHz audio file as a result.

My point was more that such a high sampling rate is not necessary for Kicks and percussive sounds, especially if used in electronic music.

1 Like