Just purchased KICK 2, can't download the license key!


I just bought KICK 2 from this site, and when i click on the license key-button i get an error message saying “Whoops, something isn’t working!”. Its really annoying!

Same thing for me here.

I had the same thing. But tried again loading the page a couple of minutes ago and now it actually downloaded the KICK 2.keyfile.

So try again, maybe the problem is gone for everybody.

Sorry it was a temporary issue with one of the servers - its since been resolved!

I’m still having issue downloading the License Key! What should I Do ? Getting this error

that is very odd

can you try clearing your cache or opening and using another browser - have tested and all working ok here

Bryan, don’t know what to say, I’ve clean the Cache, try with Safari, Firefox, and also on My PC, nothing changes.
I had this issue since the very first day I bought Kick 2. Now after 4 days still the same. Any ideas ?

Also with Google Chrome, same issue.

did you recently change your username?

Yes I did, the day I bought it. This could be the issue?

I just bought KICK 2 and I get the above shown picture if I click the “View” on the bundle I purchased. Is that the correct link because I don’t see any “LICENCE” links…

This is ANNOYING!!!


please go to Sign Up

Thank you SO MUCH :smile: