Kick 2 crashing Cubase 11 repeatedly

Hi, Kick 2 is causing Cubase 11 to crash totally, sometimes with “serious error” message and other times just a complete exit of the program

It seems very unstable - these operations have all caused a fatal crash:

Adjusting the envelope length when track is playing
stepping up and down wavs in the click modules
closing the UI

and more.

Does the plugin have a log file anywhere I can send you ?

Can you give me details of your system spec and operating system.


Hey there @TheGellski

Yes, as Phil mentioned, it’s hard to help without knowing your configuration, no one can just guess what’s happening without knowing more about your system & configuration. Please update us with the followings :

  • OS Type/Name/version : i.e → MacOS High Sierra 10.13.6 (17G14042)
  • DAW Name & Version : i.e → Cubase Pro v11
  • KICK 2 version : i.e KICK 2 v1.1.4

Then other important points like if you’re using a 32bit or 64bit version of the plugin matching your system ( especially if you’re on Windows ) and is the problem happening when using the VST or the AU plugin instance of Kick 2.

Knowing if that’s happening after a new Kick 2 installation or if it’s following an OS or DAW update can help to troubleshoot this as well a step by step description of the issue you’re having.

Thank you :wink:

Windows, 64 bit VST, Cubase Pro 11, Kick 2 v1.1.4

New Kick 2 installation, just bought and installed last week.

Step by step? I thought that was evident from my first post. Making changes to the parameters causes the VST to crash, but not in every instance. When I restart Cubase (v Pro 11) I’m alerted that Kick 2 x64.ddll caused the crash.

1 Like

Thanks for the update & details.

What I suggest to try first is to manually uninstall Kick 2 following this support thread

Do the uninstall first and I also recommend to use the free CCleaner to perform both registry & left over files clean up, then reboot your PC. Make sure you’re up to date with the latest version of Cubase Pro 11 and major Windows updates. Start Cubase once and close it, then go through a new KICK 2 installation.

On Windows it’s important that you only run the x64 installer, run it as Administrator.

Then run Cubase again and have it to re-scan your Kick 2 plugin and check if that solves the issue. It’s often tricky to be sure if it’s a plugin or a DAW issue, especially when DAWs got recent updates, so a clean uninstall/install procedure is a good point to start IMO.

Sorry, tried that. Win 10 is up to date, as is Cubase, latest version.

Even just now in a new project after reinstall, no other synths or FX loaded, editing a preset for 2 -3 minutes, I click the right arrow button to change the sound in click module 2, Kick 2 hangs, and a second or 2 later Cubase bombs entirely. This doesn’t happen with any other plugin I own.

I’ll just try and get a refund, will be easier. Thanks for your help

(PS Please don’t recommend Ccleaner, it has a terrible reputation!)

Here is the stack exception record from the Cubase dmp file - Kick 2 is identified as the offending plugin

ExceptionAddress: 00007ffc353210d3 (Kick_2_x64+0x00000000000c10d3)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000000
Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

PROCESS_NAME: Cubase11.exe

READ_ADDRESS: ffffffffffffffff

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.


EXCEPTION_PARAMETER1: 0000000000000000

EXCEPTION_PARAMETER2: ffffffffffffffff

000000000014f950 00007ffc353baf58 : 000000000000008d 8000000080000000 0000000000000000 0000000000000000 : Kick_2_x64+0xc10d3
000000000014fa30 00007ffc353b8e18 : 00007ffc35262bc0 000000000000047b 00000000610620e0 000000000014fc48 : Kick_2_x64!VSTPluginMain+0x37f18
000000000014fa70 00007ffc9119e858 : 0000000000000001 000000000014fe49 0000000000000000 0000000000000000 : Kick_2_x64!VSTPluginMain+0x35dd8
000000000014fab0 00007ffc9119e299 : 00007ffc9312bc40 00007ffc353b8dd0 00000000003307b0 000000000000047b : user32!UserCallWinProcCheckWow+0x2f8
000000000014fc40 0000000142c1add3 : 00007ffc353b8dd0 0000000000585130 00000000005fb1f0 0000000000585130 : user32!DispatchMessageWorker+0x249
000000000014fcc0 0000000142e5cadd : 000000000058c8f0 000001cc000001e3 000001cc000001e3 0000000000585100 : Cubase11+0x2c1add3
000000000014fcf0 0000000142e5c8d9 : 0000000000000000 00000000000901dc 0000000000000000 0000000000000007 : Cubase11+0x2e5cadd
000000000014fd20 0000000142be76da : 0000000000000001 00000000005fb1f0 000000000058c8f0 0000000000000000 : Cubase11+0x2e5c8d9
000000000014fd50 000000014284160f : 00000000005fb1f0 0000000000000000 000000000014fe49 0000000000000000 : Cubase11+0x2be76da
000000000014fd90 000000014287d516 : 00000000005fb1f0 000000000014feb0 0000000140000000 0000000000000000 : Cubase11+0x284160f
000000000014feb0 0000000142fa8e56 : 0000000000000001 0000000000000000 0000000000000000 0000000000000000 : Cubase11+0x287d516
000000000014fef0 00007ffc92e67034 : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : Cubase11+0x2fa8e56
000000000014ff30 00007ffc930dcec1 : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : kernel32!BaseThreadInitThunk+0x14
000000000014ff60 0000000000000000 : 0000000000000000 0000000000000000 0000000000000000 0000000000000000 : ntdll!RtlUserThreadStart+0x21

SYMBOL_NAME: Kick_2_x64+c10d3

MODULE_NAME: Kick_2_x64

IMAGE_NAME: Kick 2 x64.dll

STACK_COMMAND: ~0s ; .ecxr ; kb

FAILURE_BUCKET_ID: INVALID_POINTER_READ_c0000005_Kick_2_x64.dll!Unknown

OS_VERSION: 10.0.19041.1

BUILDLAB_STR: vb_release


OSNAME: Windows 10


FAILURE_ID_HASH: {d413e0f7-0314-ec1f-f584-b6f7cd0b6cb2}

Followup: MachineOwner

You’re giving up easily IMHO, look there’s always 3 sides of things for Plug-ins to work correctly : Your Computer “health” in terms of installation, updates & junk files maintenance as well as best setup for an audio rig, then your DAW and then the Plug-in itself.

Those 3 things can sometime be difficult to troubleshoot but it’s not likely that the plug-in is the one responsible for the issues. In your case, you’re using a brand new version of Cubase, that’s also a potential issue.

If the manual uninstall/install procedure did not solved your issue, I would suggest to refer to Steinberg support threads in order to clean up Cubase plug-ins cache & database and even thinking about a complete Cubase Reset or clean installation.

I’m running hundreds of plugins with multiple DAWs on my end, and when I’m facing issues like this, I try to follow this way to proceed, step by step. Reinstalling the Plug-in first, then forcing a clean complete Plug-ins re-scan and then resetting or re-installing the DAW giving issues.

As for CCleaner, I’m running the free version since edges and never had one problem with it, IMO it really helps to clean up a lot of junk files and especially left over and unnecessary registry keys that really stack up on your PC and slow down and seriously affect Windows performances.

I’m not running Cubase myself, so I’m not able to perform any testings on my end, so I guess there’s not much more I can suggest here via the direct help from the forums. Suggest that you open a support ticket with S.A then as well as reporting the issue to Steinberg support and send them your Cubase Log.

For S.A team → @phil_johnston any insight on this one ? Some testings on Cubase Pro 11 on your end ? Not much I can do here without using Cubase. Thanks.