Kick 2 MIDI sync

Hi everyone.

I have to report an issue happening in MIDI (and audio after bounce) when using kick2. I’m working on Ableton Live.

When i use the option freeze/flatten in ableton to freeze and flatten a MIDI track with an instance of Kick2 on it, with for

example, a one bar loop MIDI clip, i see that Kicks are not “on time” : for example a kick who’s supposed to be in 1.2 measure will be slightly in “advance” of the time…

Is there an known issue? Any solution?

Thanks for helping :wink:


We’ll certainly investigate the issue thank you -
You could try playing with the Limiter / on /off / lookahead options to see if that helps

Hey Brian,

thank you for the rapid answer;

I tried activating and disabling limiter with lookahead and release time options but unfortunatly no luck on my side.

As expected, the amplitudes of waveforms are changing with limiter and release time but the positions of the waveforms still the same.

For example, on Ableton i have my midi note related to kick 2 plugin starting at bar 1.3 and the corresponding audio waveform starting at approximately bar 1.2.8 or 1.2.9.

Hope it will help you a little to investigate :wink:

Hey Brian,

do you have any news on this issue?



I did look into this yes but was unable to reproduce the problem

could you give me a few more details - pictures of the issue / preset used / version of Live / sound card & settings (buffer size)

attached is image of KICk 2 resampled

and below is image of KICK 2 frozen and then dragged to audio channel to check

Hey Brian,

thank you for the rapid answer.

I just tried to recreate the problem but everything seems to be fine for now, quite strange…

I noticed that Ableton just updated his version of Live to 9.7.4, maybe it was an issue that comes on live’s side…

I’ll keep you updated if this problem occurs again, thank you for everything :wink:

Anyway, i will make a few tests with several presets and options to make sure this problem is solved, i’ll keep you updated :wink:

Hey Brian,

i write today because of the same issue appearing again…

I work now on Live 9.7.5, and i have a roland quad capture (soundcard) with a 256 samples buffer size setting.

i didn’t notice this issue until i install again Nerve VST from Xfer.

i’m currently beta-testing the version 10 of Live on my laptop (Xfer’s VST isn’t install on), i will try tomorrow to see if this issue occurs without the Nerve VST.

I’ll keep you updated in the problem still occurs…

In the picture, the MIDI track correspond to kick 2, the audio track correspond to the freeze/flatten version of the kick 2 MIDI track

I used the default preset on kick 2, no modifications.

Thank you :wink:

ill have to test with the latest beta and see -

does the issue still exist when you reboot ableton


I made a test on my two computers (a fixed one and my laptop) and i tried reboot ableton several times, but the issue doesn’t occur on a live set created on live 10 beta…

Hey Brian,

i just noticed the issue happening on live 10 beta…

It happened on a new Live set with only 3 or 4 tracks.

Hope that will help :wink: