Kick 2 not showing in Ableton

I have the latest version of Kick2 but i can’t get it to show up in ableton’s browser. Other plugins in the same folder work fine but Kick2 is nowhere to be found. I installed the 64 bit version. Then tried to reinstall it but nothing. Working on ableton 11.2. Can somebody help?

1 Like

I’m experiencing the same issue. I installed Kick 2 while I was still on 11.0 and and now it’s no longer visible in the VST folder after updating Ableton to 11.2. I’ve tried uninstalling and reinstalling Kick 2 but it hasn’t seemed to help.

The only way I’m currently able to see Kick 2 is if I use the AU version.

@maumanto @adameury

Are you guys using Windows or MacOS ?

If on MACs and running Ableton 11.2 in Native ARM mode, please download the latest Beta V1.1.5b from your My Account/My Downloads/Plugins area.

The Beta is fully functional and brings M1 Silicon support for MACs as well as VST3 plugin format support for both MACs & PCs.

If you’re on Windows, please make sure to overwrite the installation path when running the installer, it needs to match your Plug-ins path in settings in Live’s Preferences.

1 Like

Hi Tekalight! I’m on a M1 Mac Mini running MacOS Monterey.

It appears to be working perfectly now after installing the 1.1.5 beta.

Thank you for your help!

1 Like