KICK 2 v1.1.5b BLURRY


I tried the 1.1.5 beta version today and the UI is blurry. ANyone else have this?

  • Have you already tried to reinstall the plug-in ?
  • Have you tried to change the plug-in UI size in KICK 2 settings ?

If that doesn’t help, then could you please let us know the following details ? Tank you :wink:

  • What’s your Operating System ( Name + version ) ?

  • What DAW are you using ( Name + version ) ?

  • What plug-in format is giving you the issue ? ( VST2 - VST3 - AU - AAX ).

I’m using Windows 11, Cubase 12 Pro, VST2/3.
I’m also using a 55" display.

I’ve never had any issues with the previous version. I’ve tried re-installing and different scaling.

Installing previous version solved the issue

1 Like

Have you modified the OS scaling value in Windows Settings / Display and set it to a value above 100% ??

  • That would be in Windows Settings - Advanced Scaling Settings

It would also help to know the desktop resolution size for this 55"display.
As given for this display in Windows Settings → Advanced Display Settings

Could be something introduced with the Beta V1.1.5b if you’re not getting this issue with release version V1.1.4 then.

I will try to replicate this but that would be on Win 10 and not the same display, so not sure to get the same results.

Anyway, this will be pointed out to SA Team.

Please, let us know about your desktop resolution size and if you’re using a custom scaling value in Windows Settings, thank you :wink:

I’ve always used my Windows at 150%, 4k resolution. Never had an issue in Cubase. This 1.1.5b is the first VST I’ve experienced showing up blurry. Cubase is very good at rendering plugins. Ableton is a total mess, hence why I moved to Cubase.

Would be interesting to know if you’re still having the problem if keeping scaling resolution at 100% in Windows.

( assuming the 150% resolution you mentioned is about Windows Custom Scaling settings, and not the size of KICK 2 GUI inside Cubase ).

Pointing this out to SA team anyway, since it’s weird that the problem is not happening with V1.1.4 :thinking:

For info SA Team : @bryan_spence @phil_johnston