Logic Tutorial - Lesson 2 (How to create a drum beat 2) - Need Help

At around 4:10 in this video, it looks like he split a midi track into 5 separate parts and is now going to assign each part to the mixer individually.

He uses the + sign in the Ultrabeat mixer strip to create 5 more Aux channels. My problem is I don’t have the + sign. Did they remove it for Logic Pro 9?

I was able to add more Aux channels using Control/Command N, but I can’t assign each individual element to each channel. I can change each channel output from MAIN to 3-4, 5-6, 7-8 etc but it has no affect during playback.

All 5 elements are still coming through just the 1 audio channel.

Any suggestions?

I think you need to select the Ultrabeat as a Multi-instrument. Once you select it as an Multi-instrument, you should see the plus sign.


make sure you chose the multi output ultrabeat, not the single stereo one.

Even if you originally chose the stereo option.  Go back in the same channel strip and choose the multi out.  It will keep the same settings as the stereo option just now it will have the multi out functionality.