No response to CC7?

Using ANA 2 in Digital Performer. Liking it in general, but…

Surprised to discover that it doesn’t respond to the standard MIDI volume controller that is generated by the fader on the controlling MIDI track, CC7. Furthermore, the Volume control at the top of ANA 2’s GUI is apparently not MIDI learn enabled.

There are, of course, other ways to control the output level, but response to CC7 seems like an odd thing to not have available by default.

Am I missing something?

What DAW are you using ? In Live 10, the Main Volume Control knob on ANA 2’s GUI is responding to automation straight out of the box for me. You can then assign this automation to a controller fader/knob for some live recording volume automation.

Next to that there’s also the dedicated OSCMixer section in ANA 2 allowing you to write volume automation per OSC which is a big bonus IMO, furthermore those ones are CClearn enable too.

That’s my way to do it when it comes to volume automation with ANA 2 and I find the existing feature quite convenient already :slight_smile:

Anyway, just my 2cts point of view here & SA team & the devs are monitoring the forums, so they will see your post too.

In Digital Performer. Doesn’t respond to the Fader in the MIDI track assigned to ANA2, nor to CC7 OR CC 11 recorded in the track.

Also doesn’t respond to either controller in MainStage.


Just to clarify, when I’m writing “the Main Volume Control knob on ANA 2’s GUI is responding to automation straight out of the box for me”, I mean that the main Volume Knob in ANA 2 is recognized as “Output Gain” parameter and that I’m able to write matching automation modifying the red automation lane in Live. Then Mapping this Live automation Lane to a fader or a controller will require another step as shown on this pic.

Not sure how automation works in Motu DP and if it’s even available in Mainstage, but in Live the ANA 2 main Volume knob is showing up in automation by default even if the knob itself has no available Midi Learn feature.

Thanks for taking the time to try to understand my issue.

Maybe DP is different… it uses two ‘strips’ in the Mixer. The virtual instrument is instantiated in a special “instrument“ strip, then there is a standard MIDI track that you set to point to the instrument (for example, an external MIDI module, or an internal “ instrument” track where ANA 2 is instantiated). When you move the fader on the MIDI track, It sends CC7 to the target device, in this case, ANA 2 in a virtual instrument track.

For some reason your plug-in, unlike virtually every other instrument plug-in I own, does not respond to moving the fader on the midi track, nor does it respond to MIDI controller 7 data that is recorded in that MIDI track, or MIDI volume (CC7) data sent by the keyboard that’s triggering the notes. it also ignores CC4 (pan) and CC11 (Expression), which are very commonly used MIDI controllers. This is different than automation data, which is (as I understand it) not necessarily MIDI.

I can record automation data directly into the instrument strip, and that will control the volume during playback, however that is a non-standard way of working and only works if I record the automation. The ‘ normal’ way of automating volume and pan in DP is to automate the MIDI track’s fader and pan knob, which sends CC7 and CC4 to ANA2, and has no effect. I am used to being able to easily control the volume of a plug-in while I’m working. For example, to simply use the hardware controller’s Volume fader (sends CC7) to change the level of ANA 2. In summary, your instrument doesn’t respond to any of these common MIDI messages sent from a MIDI track, or the hardware controller that is triggering the notes.

Also, I would like to use the plug-in for live performance within Apple’s Mainstage. In Mainstage, each instrument strip has an expression control that automatically is mapped to CC 11. Your instrument does not respond to CC 11 as I would expect a virtual instrument to. Although I can map my expression pedal to ANA2’s Master Volume knob, Expression is designed as a secondary volume control, so the nominal level can be set with CC7, then CC11 used for “expressive” level changes. This makes it cumbersome to have the volume controlled by my expression pedal when I’m playing live.

Thanks for listening!

1 Like

Hi again there,

Thanks for this detailed feedback & explanation about how things are working inside Motu DP & Mainstage and how you’re expecting ANA 2 plugin to behave & respond to these Midi CC values.

@bryan_spence & @phil_johnston do you guys know any work around for this or does it look like something missing that could be added to the feature requests ? Thanks.

Yeah this is something that probably needs looked at.

A possible workaround would be to assign the main volume to a macro then in settings adding the macro knob to the 007 midi control.

This might give the same functionality.

I’ll add this too our features list

1 Like

Thanks- I suggest you add the response to (at least) CC7 and CC11, ‘essential’ for use in live performance and direct control from a hardware controller. Pan (CC4) is pretty much expected, too, for sequencing… It’s nice to be able to use MIDI streams for this as well as ‘automation’.

Also, why not at least have the master Volume knob MIDI Learn-able.

Curious was this ever resolved… Cakewalk uses a similar setup. I haven’t yet figured out how to get CC7 to control volume of the notes (granted, I’m not as versed on using midi controls) but it doesn’t seem to be happening by default.

So in fact this is DAW dependant I think ( at least to get automation as shown in my previous screenshot ), the Master Output is not directly assignable with right click inside ANA 2 ( like other parameters are ).

But if you use the Modulation Matrix, you can set the following modulation using the VOLUME ALL parameter and assign this to a Macro and you should then be able to map this Macro to a Midi controller.

But keep in mind that the final output level is always defined by the Master Output Knob, which in fact can be useful : i.e : you can set the Master Out to -6db for example and never exceed this final output level when tweaking the VOLUME ALL via the Macro.

@phil_johnston already posted about this on the ANA channel for the devs, but I think there’s a reason for the Master Output not being assignable as this would cause other issues I believe. So not sure if this can/should be implemented.

When I assign a Macro to Volume All, it won’t reduce the volume, only seems to increase it. If I set it to inverse action, it does as expected- control all the way up = silent, all the way down = full volume. How can I get it to work with standard (down = silent, up = full volume)?

Frustrating. I LOVE this synth, but it’s unusable for me this way. I NEED LIVE EXPRESSION CONTROL.


MACROs are based around percentage : 0% means the Macro isn’t applied at all and 100% it’s fully applied.

So I don’t think it’s possible to have this working the way around in the way it’s implemented right now.

It works as shown in the post above ( and explained below ) :

1 - From the Macro Matrix view :

  • If you assign MACRO 1 to Decrease ( Macro Matrix Arrow DOWN ) the VOLUME ALL parameter value.
  • The Slider at 100 means that the Macro affects the entire value of the VOLUME ALL Parameter.

2 - Then from the Main Interface & the MACRO’s knobs :

  • The knob turned full left means 0% of the MACRO is applied → Max Volume Out ( based on main Out ).
  • The knob turned full right means 100% of the Macro is applied → No Volume Out at all.