Node Crash Bitwig


When opening a factory preset in Node and then adding/activating a new/additional “frame”, the plugin crashes in Bitwig 3.1.3. Windows 10.


Hey there @Joachim

Could you please specify if this is happening with both the VST or VST 3 plugin format inside Bitwig or just one format ? Thanks.

  • Need to update to Bitwig 3.1.3 before testing this on my end under Win 10 Pro 1909, will do that tomorrow & will update here after trying to replicate this.


@Tekalight I left the studio for the day but I’ll check tomorrow. I think it was VST3. I’ll try it again and make a note which preset I tried to edit and if it happens with more than one preset.

1 Like

I tried it again and only got the VST2 version to crash but there was no specific order to it, nothing I could notice. I just went through a few analog presets, adjusted some of the frames and after a few minutes it crashed. I couldn’t get the VST3 to crash. I’ll try the VST2 again tomorrow after the 0.93 update.

1 Like

Hey again @Joachim ,

Thanks for those updates :wink:

I wasn’t able to replicate this under Windows 10 Pro 1909, either with Bitwig Studio v3.1.2 or latest v3.1.3.

I couldn’t get Node to crash inside Bitiwig when switching/loading factory presets and then activate/deactivate “Frames”, no crash here if I stick to these actions → Presets Change & Enabling/disabling new “Frames”. Tested with both VST 2 & VST 3 without issue.

So here is the question, when you mention “adjusted some of the frames”, does that mean that you’re also trying to create/modify “Nodes” ( the dots on the waveform itself ) ? Which is something different than just enabling/disabling “frames” ( the squares boxes slots ).

I do have Node crashing inside Bitwig 2.1.2 & 2.1.3 when loading/changing factory preset → then revert to Init preset → and trying to add a new “Node” → crash.

I’ve also seen some errors in Bitwig Engine.log file ( found in C:/User/Username/AppData/Local/Bitiwg Studio ) each time I load/switch preset using the VST 3 plugin, as well as some information when the previous described crash happen. I will send this to S.A team as well, but back to this one, couldn’t get a crash just playing around with the frames, so need to know if you tried to create new “nodes” at the same time, then it could be related or similar to this issue reported with the standalone version here : Node Beta - Standalone crash

@Tekalight Yes, I was also trying to create and modify new nodes. It only happened twice so far but it could very well be that I went back to an Init preset. It was the first time I opened Node so I didn’t pay too much attention to the sequence of events. I just wanted to see how it works. However, it crashed pretty quickly. The second time, it took a bit longer to crash. Also here I was enabling frames, then changing nodes as well as using the free draw function. This time only the VST2 version crashed. I couldn’t get the VST3 version to crash. I’ll have to check the Bitwig engine file. My main DAW is Cubase so I haven’t paid much attention to the Bitwig engine files.

1 Like

Thanks for this update @Joachim , I will send what I could get from the Bitwig Log file to S.A team on Monday, but yep, it looks more that it’s something to do with reverting to Init or changing preset & then trying to create/modify the nodes.

Hopefully it would help them to sort this out, thank you again for your feedback :wink: