Patches Lost after Update

I´ve a problem with my ANA2. I updatet last week from v2.01 to the latest version. But studio one cant load the latest version and blacklistet the vst. So ive reinstalled my old working version. Now all my presets are gone. Every song i open with ana2 has now the “A Beatiful Dread Lead” preset. Why is this happen? And is there a chance to get my own generated presets back? Has anyone else problems installing latest ana2 in Studio one?

I use windows 10 pro and studio one 4

Thx greetings

Hey @Bjoern_K

So since you’re on Windows 10 Pro could you please check if you still have this folder :

WIN : C:\ProgramData\Sonic Academy\ANA 2\Presets

and then from the Presets folder, you should find a Sound Presets sub-folder which contains DLC, Factory and & your “User” presets folder.

If you just reinstalled ANA2 on top of your previous version without doing a clean uninstall/reinstall your presets should still be in there.

Edit : So, if you’ve got this folder structure preserved, the first thing you want to do is to copy & backup your presets before running into a new installation again. ( Please note that the “ProgramData” folder is hidden by default under Windows, you’ve got to use the explorer properties to modify this, google it if in doubt.
Let me know.

Hey @Bjoern_K

I just finished installing Studio One 4 latest version on a up to date Win 10 Pro x64 machine here and I can tell that I’ve got ANA2 v2.0.81 working without any issue & with all presets too.

Be sure to install & use the ANA2 x64.dll file ( assuming you’re using a x64 Windows system ) but take care of your presets first if you want to have a chance to save them.

Hey Tekalight,

thank you. I will check this out later after work. But i dont realy think that this will solve the problem. But i will have a look for this later. C:\ProgramData\Sonic Academy\ANA 2\Presets seems to be there.

But i think i´ve choosen the wrong title for my problem. Not my saved user presets are gone. My unsaved patches are gone. ANA2 did not remember the last plugin state.

I found someone with the similar problem on the kvr forums

ANA2 is really nice in theory but I stopped using it due to the preset loading issue. Even in the latest beta version, the plugin will still sometimes forget the last plugin state when a project is loaded into the DAW and instead reinitialize ANA2. This is exceptionally annoying. Probably the most annoying bug I ever came across in a synth plugin. It seems to me that making sure the plugin loads correctly should be one of the top three priorities a developer needs to take care of

Best greetings

Hi there

The person on kvr sounds like they were using the beta - which was quite some time ago.

The most likely reason you would be experiencing the default preset loading each time is if you are running an older version of the plugin than you had installed previously.

Or if you’ve resaved your projects with the newer version and then reverted to an older plugin version again

1 Like

Yep, confusing indeed… :smile: and you started mentioning on FB Group that ANA2 did not pass validation with Studio One and was blacklisted so I was assuming a different issue. Bryan post is pointing you in the right direction then, be sure not to have mess up with several installations and the .dll files. After a backup of your user presets ( if you own other presets packs you can always reinstall them ) it could be good to perform a clean uninstall of ANA2 before downloading a fresh latest version from your account and do a clean install again. Tools like the IO Bit Uninstaller can help to perform a clean uninstall. Have a look here Download IObit Uninstaller 12 Free - 100% Free Uninstall Programs & Plugins

Got it working! :smiley:

oh that was boring trial and error but finally it works again and it was no ANA2 problem!

I used iobit to remove Ana2 and did not recognized that i´ve checked “Delete Automatically” all files … So all files within my vst folder where deleted … Damn! I use iobit a lot and auto delete works fine. But did not think about it that the other files within the vstplugin folder are no files from ana… So i´ve to installe my Plugins again … and run into the same error as before with ana2. Now i know… the problem is anywhere else … So i checked my Studio One 4 settings folder and found some logfiles. “VST Scanner crashes” … ah ok why? Looking deeper i found that there are file permission problems reading from C:\Programms\vstplugin (i dont know why it worked before)… copied all content to antoher location and point to it within studio one… rescan … no errors … open some projekts … ana2(latest version) is there and the best … my patches are also there! yes!

So thank you very much guys for your help!

ANA is back fun is back :slight_smile:


Oups man, sorry to hear the headache with IO bit, those tools help but you’ve got to be careful in the settings before running them :wink: and yes, weird folders & files permission also happens.

I took the habit to place my VST .dll plugins files in sub-folder classified by Manufacturers:
for example I will have c:\program Files\VSTplugins\Sonic Academy\ANA2 x64.dll a few plugins would cause me trouble and I have to let them in the main VSTplugins folder, but most of the time it works.

Well glad you get it sorted anyway & got your presets & projects back, thanks for reporting back here.

Cheers !