SA76 went back to Demo mode after my subscription got renewed

today my subscription got renewed and SA76 went back to Demo mode. When I try to reactivate it
it says, my computer has already been activated. Revoking my device didn´t help either.

Any ideas?

Hey there

  • You should be able to reactivate the plugin after revoking your device from your account.

  • Are you on a Mac or on a PC ?

  • Have you installed the release version V1.0 and make sure that you don’t have left over files form a previous Beta installation ?

Hey, thank you for answering.

  • Revoking my device did not help.
  • I am on PC
  • It´s version 1.0. I did not have the beta installed.

Might be obvious, but first make sure that your subscription is active, you can check this in your My Account/Subscription area and if you’re able to access all courses online.

Then try a Clean Install :

SA76 Clean Install Procedure :

1. Close Any instances of SA76 and close your DAW.

2. Remove the entire SA76 folder located here : C:/ProgramData/Sonic Academy ( The ProgramData folder might be hidden by default on Windows, you’ll need to Reveal Hidden Files & Folders )

3. Remove the entire SA76 folder located here : C:/Users/ Your-Username /AppData/Roaming/Sonic Academy ( again, the AppData + subfolders might be hidden by default )

4. Remove all SA76 2 plugins :

  • AAX : C:/Program Files/Common Files/Avid/Audio/Plug-Ins remove SA76.aaxplugin

  • VST : C:/Program Files/VSTPlugins remove SA76.dll ( an alternative installation path could be C:/Program Files/Steinberg/VSTPlugins depending of your install ).

  • VST3: C:/Program Files/Common Files/VST3 remove SA76.vst3

5. Restart your PC.

6. Upon restart, install the latest version SA76 V1.0 downloaded from your account My Account / My Downloads / Plugins

7. Start your DAW with a NEW EMPTY project and launch a new instance of SA76.

8. You should be prompted by the authorisation screen : activate the plugin by entering your account Username + Password .

If you’re still having issue after this, shoot an email at support

The clean install helped, thank you very much.
I hope, I don´t have to do this every month now :wink:

All the best

1 Like

Thanks for your reply and happy to read this is now sorted :+1:

Hopefully not, it shouldn’t be the case :sunglasses:

I’ve got the same issue, the plugin keeps reverting to demo mode.
Whilst troubleshooting I’ve revoked and re-registered multiple times, thinking that would help. I guess I was wrong.

In total I’ve registered online twice and offline twice, all on the same desktop machine.
My 2nd online registration is currently the “active” one but only because I’m not allowed to revoke it.
In my account page I get the message “you can only revoke 2 devices in a 30 day period”.
This leaves me unable to use the plugin since I’ve also revoked my 2 offline registrations and I can’t create a new one (error message: License registration failed, you aren’t allowed to register additional devices).
I had no choice but to revoke (and re-register) in order to use the plugin again.

So now I’m in a situation where I’m registered according to my account page but can’t use the plugin since it’s stuck in demo mode.
I can’t re-register anymore (online or offline) and I can’t revoke due to the max 2 revoke limit per 30 days.
I’ve also followed the above instructions in this thread but these didn’t help.

Some extra information (maybe a bug?):

I’ve had something similar happen with Kick2. I tend to save the plugin in whatever project I’m working on in Studio One while I’m demoing/evaluating.
When I open up the project file AFTER purchasing the plugin, the plugin seems to think it’s still in demo mode?
For Kick2, it was just a matter of removing it from my project, then loading a new instance of Kick2 in the project. After saving the new project file, all was good on subsequent reloads.

Please help in resolving the SA76 issue for me, I do not want to be locked out for 4 weeks (after which I have to revoke and re-register again).
Maybe the support team can revoke my registered device remotely so I can properly attempt the above mentioned instructions in this thread.
I can provide screenshots of my account page if needed (for device-ID etc.).

Thanks in advance.

There must be a bug - I will check this out.
Sorry for the inconvenience guys will resolve it asap

Hi. Revoking didn´t help me either.
I followed Tekalight´s instructions for the clean reinstall. That helped.

I hope this issue gets solved soon.

All the best.

1 Like

Hi again

we’ve identified the issue - should have a fix out shortly for it


@NikiSato this might happen again after a while I’m afraid.

But like Bryan already mentioned, the bug is now identified and should be fixed soon :+1:

1 Like

Thank you :+1:

1 Like

@bryan_spence Excellent! Glad to hear this :slight_smile:

there is a new version in your account if you haven’t already been prompted to update

1 Like

Unfortunately the same problem still exists. :frowning:
It keeps going back to demo mode until all revokes/activations are depleted again and you get stuck in demo mode.

After installing 1.01, I still had 2 previously activated device-ID’s back from 1.00 in my account that I had to revoke before being able to activate 1.01.
This worked, until the next day.

When I fired up Studio One, it was back to demo mode for SA76 and looking at the demo nag screen.
Over the next few days I had to revoke and reactivate multiple times, including an offline registration.
Now I’m stuck in demo mode again due to the 30 day, max 2 revoke limit.

This is getting pretty frustrating.
I’m not an SA subscriber but bought SA76 outright, I’ve tried SA76 in both Studio One 6.1 Pro and Reason 11. I’ve tried both the VST2 and VST3 versions, I uninstalled everything using Tekalight’s instructions in this thread and reinstalled multiple times, the problem persists.

Please investigate, thanks.

Shoot us an email at support

We can arrange a remote Teamviewer session with you to check your installation.

Only support can reset the 2 devices/per month revokes limit and look further into a potential other issue with the license, I’m afraid that won’t be possible through the weekend tho.

apologies for this - it seems there is an underlying bug/issue in the framework that we use for our plugins - we are currently investigating a work around until they fix it - in the meantime i have revoked all your devices so that you can get up and running again

1 Like