( Solved in v2.0.98 ) : ANA 2 Blank Gui & Freeze inside Live 10 - Win 10 /Vst 2/Vst 3

I got the same problem: DAW freezes but not treated by Windows as “Not responding”.

Windows 10 20H2, Ableton Live 10.
System is 64-bit, ANA2 VST also 64-bit.

Happened with VST3 and VST2 versions.

I feel like it’s a something with recalling UI or skin?

Please note that i use custom skin (my own modification of only 1 png file.)
You can see the one colored ANA2 instance that was working. And the white one which hangs out for ever.
The white one i opened because i wanted to tweak preset settings.

My Scenario:

  1. Open Ableton for sound design session (not busy project - basically empty)
  2. Add ANA2 instance. Init preset tweak it.
  3. Forget about Ableton for couple of hours.
  4. Return to sound design.
  5. Tweak preset. Save.
  6. Add another ANA2 instance.
  7. Init. Tweak preset.
  8. Switch to youtube, forum - forget about Ableton for ~30 minutes.
  9. Comeback to DAW, one 2nd instance, play with it.
  10. (I think) While 2nd instance is still playing sound (AMP envelope not finished yet) open UI of 1st instance.
  11. UI opens blank and… that’s it - not possible to click anything inside DAW, not possible to close DAW (Windows does not see it as a “not responding”)

So in my scenario DAW transport was not even running, i just improvised on midi keyboard. I did not have described problem on previous version.

Thanks for reporting this :wink:

Made a separate topic since the original one is related to FL Studio and the issue might be a different one.

Haven’t tried to replicate this yet since your scenario is a bit specific, do you have the same issue when using the default skin BTW and do you have the same issue in a more straight forward that doesn’t imply leaving Ableton open for some time in the background and going back & forth between Live & other applications ?

I can reproduce it with simple steps!
Default skin, all midi controllers turned off.

  1. Open Ableton Live.
  2. Remove all pre-inserted channels except 1 midi channel for adding ANA2.
  3. Add 5 instances of ANA2. (I did not try do duplicate - open each new instance from browser)
  4. Open all UI one by one (DO NOT CLOSE PREVIOUS) - you have 5 ANA2 UIs open.
  5. Go to first instance, all of the UIs are open: close and re-open the 1st.

Sometimes it hangs out here. Sometimes i need to go and repeat with 2nd instance.

It feels like opening every next instance takes longer between white screen and rendered synth panel. Until it goes into infinity.
If you could not reproduce with 5 instances - please try more extreme number.

1 Like

I’ve been able to reproduce this under Window as well, even with only 2 instances of ANA 2 loaded inside Ableton Live.

Same scenario :

  • Open Live - Delete all return & extra default track just keeping one Midi track.
  • Load ANA 2 on the Midi Track
  • Load a 2nd instance of ANA 2 on a new Midi track
  • Both ANA 2 GUI are open
  • Select the 1st Midi channel & try to close & reopen ANA 2 GUI ( either using ANA 2 GUI or Live’s Device )
    → ANA 2 GUI is re-opening as a complete white screen, Live seems unable to recall the GUI and goes in infinite loop - Live just hangs and doesn’t crash & Windows is not reporting that Live isn’t responding but the Task Manager reports a “Very High” resources usage → you then need to manually kill the process via Task manager.

Happening with both VST 2 & VST 3

Tested on Live 10.1.30 as well as 10.1.35 ( last test done with only Live 10.1.35 install with a fresh install following a manual uninstall & PC reboot ) → so Live is set to default.

Win 10 Pro with latest updates & following specs :

Processor Intel(R) Core™ i7-6850K CPU @ 3.60GHz 3.60 GHz
Installed RAM 32.0 GB
Edition Windows 10 Pro
Version 20H2
Installed on ‎10-‎Jun-‎20
OS build 19042.964
Experience Windows Feature Experience Pack 120.2212.2020.0

On the same machine but with MacOS 10.13.6 High Sierra ( since I’m running a Hackintosh rig ) I ran a test with 10 instances of ANA 2 and I had no issue to close / reopen ANA 2 GUI inside Live 10.1.35

FYI → @bryan_spence @phil_johnston

1 Like

The problem no more happens on latest version


Thanks for the feedback :wink: