( Solved in v2.0.98 ) : Bug Report-v2.0.97 GUI --> MOD ENV 4 missing

Hello everyone, i just purchased ANA2, and i can see from the manual that there are 4 Mod envelopes, however my version of the synth only has 3. How is this possible?


Hey there @Rivertropic

Thanks for your feedback :wink:

Yes, I’ve got the same layout here with v2.0.97 ( only checked on MacOS for now ).

Looks like a problem with the v2.0.97 skins ??

→ Using either the “default” or “black” skins, loading a new instance of ANA 2 will display only 3 MOD ENV.
→ Loading a custom skin from older version from the options display 4 MOD ENV
→ Reverting to the default/black skin keeps the 4 MOD ENV display on but then closing the GUI window and reopening it revert back the display to only 3 MOD ENV.

Pointing this to S.A team.

FYI → @bryan_spence @phil_johnston

@bryan_spence @phil_johnston

Could it be this ? Removing the extra " Buttons/ " in line 234 of both Default & Black GUI layout.xml files solves the problem for me.


Thank you very much Stéphane! That worked :slight_smile:

1 Like

Yes, you can edit and correct this file in both locations and it seems to do the trick for now but just keep in mind it’s only a quick workaround at the moment and totally “unsupported”.

We need S.A team to confirm the bug & then it will be corrected for a future release :wink:

Cheers !

nice catch!

i’ll push that change up in the next release

1 Like