( Solved in v2.0.98 ) : Loading ANA 2 inside running project freezes DAW ( Win10-FL Studio 20-ANA2 2.0.97 )

Hello there,

Just downloaded the new ANA2 version and I noticed that if I try to open the plugin when play is on (by the way… this happens in FL Studio 20 latest release)… the sound keeps going but ANA2 instead of opening freezes the DAW completly.

One thing to notice is that the DAW itself is not recognized by windows as a “Not responding process” , it’s like the DAW is still working but it’s completly frozen… can’t explain better than this ^^‘’’

Hey there @Svalinn85

Just to recap & trying to narrow things down :wink:

WIN 10 - FL Studio 20 latest → What are your computer specs ?

Do you have this issue with the VST2 or VST 3 specifically or both plugins ?

Also, is this happening when running a project with already a certain amount of channels or another virtual instrument that might already use quite some CPU or do you experience this even with a light project that you’re sure isn’t already taking too much resources ?

Thanks :wink:

Windows 10, FL studio 20 latest release, VST3.

My computer is not very good (actually it kind of sucks for music prod but I do my best) but this did not happen in the previous version.

Happens in both full project with different instruments and also ahppened in small ones with no more than 3-4 channels going.

Did not happen on a completly empty one were ANA2 was the only instrument.

Definitly not CPU related. Even in the bigger project I tried bouncing everything to audio BUT the ANA2 pattern… CPU consumption was like 30% after and it still freezed over.

1 Like

Thanks for the update :wink:

Not into development myself but from what I know from it, VST 3 are usually more resources consuming. Next to that, we have to keep in mind that it’s the first iteration of VST 3 for ANA 2, so the developers might improve the code in that regard in future versions.

As Phil wrote in another post, there’s no real benefits to use the VST 3, I know it provides certain features like automatic track name reading & such but it’s not something very useful for a synth in the end. So if you have no issue with the VST 2, it’s probably better to keep using it for now IMO.

→ FYI @bryan_spence

It’s just that FL Studio automatically “merge” Vst2 and Vst3… so I’l just try to uninstall and reinstall without putting vst3 in xD

Nevertheless… I hope my post can help adjust eventual problems :slight_smile:

Thanks for suggestion for now :slight_smile:

Before you re-install try to have a look at your settings into the “Plugin Manager” from the top Options Menu.

I’m on a Mac right now but I’m expecting the same settings on Windows ( though I could be wrong ) but you can choose what Paths are active for Plugins scan as well as combining or not VST & VST 3.

Also, you don’t need to re-install ANA 2 if the option aren’t available on Windows, you can simply move or delete the VST 3 Plugin itself if you’re sure you won’t use it for now.

Location on Windows should be : C:/Program Files/Common Files/VST3

Hope this helps :slight_smile:

Cheers !

A post was split to a new topic: ANA 2 Blank Gui & Freeze inside Live 10 - Win 10 /Vst 2/Vst 3

Took a little while to get back at this… but I can now confirm that it freezes even when using the VST2 format.

I also confirmed that the only thing needed for it to freeze is to try and open up the ANA2 interface while the track is in play mode… actually happened in a sound design session with only kick, Hi Hats, Snare and ANA2 Bass (that I was designing) right now.

EDIT: New thing… I’m starting to believe there is an issue with the GUI loading because now it’s freezing also if I try and open up the troublshooting options of the wrapper and then go back to the GUI…

Track is not playing right now, it’s on stop… it still freezes the daw trying to open up the GUI.

1 Like

Can you confirm if you are running 32bit or 64bit version of windows ?

The latest release of ANA 2 dropped 32bit compatibility.

So if you are running windows 32bit FL will be using a wrapper to make it work which is particularly stable.

Yes. I have windows 10 pro 64bit

This is looking very similar to this other issue that has been reported, looks like it’s specific to ANA 2 under Windows, for both VST 2 & VST 3 with latest v2.0.97 → ANA 2 fails to recal the GUI in certain circumstances ( like having several instances inside the DAW ) and leads to infinite loop that will freeze the DAW.

Also happening with Ableton Live, so this might not even be specific to FL Studio.

I have updates on the issue… and 1 question.

Let me start with the Update: ANA2 at the moment doesn’t even start… or well… to say it better… It emits sounds but it does not open the UI at all… and it still keeps freezing everything.

I’ve tried in:

  • FL Studio
  • Harrison Mixbus
  • Reaper ( I downloaded it with the specific purpose of trying this out)

In all of these three DAWs ANA2 now doesn’t open the GUI at all and freezes everything.

This said my question: does ANA2 upgrade on it’s own whan a change is made? Because otherewise I do not understand how is it possible that it got worse with no upgrade on my part in the last couple of days ^^‘’’

No, it does not upgrade on its own - Maybe you’ve changed the GUI skin ? Some people are using custom skins and those older skins won’t work, the GUI will just not open, so only use the “default” & “black” skins with v2.0.97 for now.

Try this to see if it solves the issue for now :

  • With your DAW & ANA 2 closed
  • Go to C:/Users/Your_User_Name/AppData/Roaming/Sonic Academy/ANA 2
  • Delete your ANA 2.settings file inside this directory
  • Restart your DAW & launch a new instance of ANA 2

This should reset ANA 2 to default settings and revert the GUI to the “default” skin & size.

Uhm well… I don’t even have custom skins and I usually just use the black one ^^‘’ Also… the GUI does not open not only in FL Studio… but also in Mixbus and reaper… just o be clear… I never ever opened ANA2 in mixbus… and I just downloaded reaper just for tests… so I guess it should just load the default ones but it doesn’t.

I’ll try that for FL tho you never know thanks :slight_smile:

Following on this, I did try to open ANA 2 v2.0.97 inside MixBus this wk and it’s working on my end, so this might be something else. For info I’m running MixBus 32c v6.2 on Windows 10 Pro.

Maybe a manual uninstall and a new install could help with v2.0.97, but at this point I think you should ask support a link to a previous v2.0.94 installer, do a clean uninstall before running the installer and keep using this version until issues in v2.0.97 are solved with a future update.

You can open a support ticket here.

1 Like

we are testing a new build now that should resolve these issues :+1:


Cool, I hope the reports were helpful in figuring this out :slight_smile:
Also thanks Tekalight for the help :slight_smile:

1 Like

check the account area now please - hopefully your issue is resolved in 2.0.98

1 Like

Tried it out almost immediately. Seems to be working fine now and it’s not freezing for me so thanks a lot.

Should anything come up I’ll be sure to signal it here on the forum :slight_smile:


Great :blush: