( Solved ) Kick 2 window not working

Hey there. I managed to install Kick 2 properly but now I tried to use it and when I click inside Ableton on the Kick 2 VST to open the plugin its opening but I can only see the „exit“ button of the window. I tried to enlarge the window but it didnt work. I’m also using the correct x64 version of Kick 2. I will add a screenshot of it how it looks like. Maybe someone knows a solution? Thank you for your help🙏

Here is the screenshot:

Hi there @Raschun10

Quit & close your DAW and try to delete your KICK 2.settings file then reopen your DAW and try to launch a new KICK 2 instance.

You’ll find the settings files in the following locations :

  • Windows : C:/Users/Your_User_Name/AppData/Roaming/Sonic Academy/Kick 2

→ AppData folder might be hidden by default on Windows, you’ll need to “Reveal Hidden Files and Folders”

  • MacOS : Users/Your_User_Name/Library/Application Support/Sonic Academy/Kick 2

    → Please not that this is the USER LIBRARY on MacOS, not the system library.

Check this link or try this :

1.Open a Finder window.
2.Select Go → Go to Folder… in the menu bar.
3.Type ~/Library/Application Support/Sonic Academy/Kick 2 in the input field and click Go.

Make sure to use the latest version of the plug-in ( downloaded form your account ) and please report back with your Operatinf System + DAW version number if you’re still having issue.

A manual uninstall and a clean new install might also help, but try the above method first.

Oh yep I replied to the wrong topic.
Anyways, this worked! Thank you very much! Cheers :slightly_smiling_face:

OK, no worries, I’ll delete my reply there.

BTW for my info, was it enough to delete the settings file or did you have to reinstall ?

Thank you for the update :wink:

Hey, deleting only the settings file wasn‘t enough I had to reinstall then it worked :slightly_smiling_face:

1 Like

OK, thank you for taking the time to reply and your feedback, much appreciated :thumbsup:

Cheers !

reinstall it and re register the device and it worked again. thanks for the help :slight_smile:

1 Like