StudioOne ( macOS VST2 vs VST3 fails to load

Hi, I think there was another thread outside the beta area about a similar issue with Studio One, but I tried the latest available beta (2.0.993b) and am running into the same issue.

Old songs that have VST2 versions of ANA2 fail to find the VST2 version when the VST3 version is available. It actually looks like the VST2 version “device” is named “ANA2” and the VST3 version is named “ANA 2” (with a space) - I’m not sure if this is the root cause for the VST3 version not getting automatically picked up or not.

Moving the VST3 version of the plug-in out of the /Library/Audio//Plug-Ins/VST3 folder allows the old songs to load/play correctly, but I haven’t figured out a way to upgrade without manually copying/replicating all the settings for each track.


Hi there @docBliny

There should be no space in the VST3 ANA 2 plugin name ( talking about the installed plug-in file name here, not the name that might be shown inside Studio One ), so it could be something wrong with your installation and manually replacing plugins.

By design the latest version of ANA 2 includes the feature to automatically replace the VST 2 with the VST 3 and Studio One takes advantage of that feature, so as a result, your projects using VST 2 should be replaced with the VST 3 and Studio One won’t list the VST 2 in the available plug-ins, even if it’s installed.

That should be the normal behavior.

Check what plug-ins versions you’ve got installed on your Mac :

Locate both plug-ins, right click on each one and select “Show Package Contents” → Then open the “Contents” folder → Select the .plist file and click on your space bar to view it : All plugins should indicate v2.0.993 for the “ShortVersion” string.

If you need to, go through a complete manual uninstall procedure as follow :

!! Please make sure to back up your User Presets before going through a manual uninstall of ANA 2​ !!

  1. Close any instances of ANA 2 and close your DAW.

  2. Remove the core files in the USER LIBRARY : remove the entire ANA 2 folder located here :

~/Library/Application Support/Sonic Academy/

  1. Remove all ANA 2 plugins : ( this time the main Library, not the user one ).

AAX : Machintosh HD/Library/Application Support/Avid/Audio/Plug-Ins remove ANA 2.aaxplugin
AU : Machintosh HD/Library/Audio/Plug-Ins/Components remove ANA 2.component
VST : Machintosh HDLibrary/Audio/Plug-Ins/VST remove ANA 2.vst
VST3 : Machintosh HDLibrary/Audio/Plug-Ins/VST3 remove ANA 2.vst3

  1. Reboot your Mac.

  2. Upon restart, install the beta version ANA 2 v2.0.993b downloaded from your Account My Account / My Downloads / Plugins ( you’ll need your license file as well if it’s not already on your computer ).

  3. Test again and report back.

Thanks for the steps to troubleshoot. Unfortunately, I’m still seeing the same thing.

Both VST2 and VST3 files had “CFBundleShortVersionString” as “2.0.993”. I did the full manual uninstall, rebooted, re-installed v2.0.993b, and then restarted Studio One. I also double-checked that there weren’t any other VST paths set in Studio One and reset the block list / set to rescan on startup.

When I open one of my old songs I still get the same error. I did notice that I get a beachball for a few seconds when the song is loading on “ANA 2”, but then the load continues. I checked Console but didn’t see any errors or warnings or anything else of interest searching for “ana2” or quickly scanning entries for “studioapp”.

The space I was referring to is what I see in Studio One as the “Device name”. The track has “ANA2” for the existing tracks, and if I drag a new VST3 to create a new track it has “ANA 2”.

In case in helps:
macOS Big Sur 11.6.1
MacBook Pro (15-inch, 2019)
2.3GHz 8-Core Intel Core i9
Radeon Pro 560X 4 GB

Would you know with which version of ANA 2 those older projects were made ?

It could be an issue with using an older version of the plugin that was not implementing this feature yet.

Could you please try the following :

  1. Move ANA 2 VST 3 plugin from it’s install path : /Library/Audio/Plug-Ins/VST3/ANA2.vst3 to your Desktop
  2. Launch Studio One and start a New Project.
  3. Now you should only have ANA 2 VST2 available → make a couple of tracks with ANA 2 → Save your project.
  4. Close Studio One and Move back ANA2.VST 3 from your Desktop to the VST3 plugins folder.
  5. Try to reopen this New Saved project and check if ANA 2 VST3 is now replacing the VST2 as it should be.

If that work, then you could try to remove the VST 3 once again, load your older projects and save them again with VST2 v2.0.993, then move back the VST 3 again and give it a try.

The goal here is first to be sure that the VST3 replace VST2 when available feature is working for you with 2.0.993

That did the trick. The streamlined steps that worked:

  1. Move ANA2.vst3 out of /Library/Audio/Plug-Ins/VST3 to another location, such as the desktop.
  2. Open Studio One, open the old project, play to verify ANA is working, save the project, repeat for any other projects, and then close Studio One.
  3. Move ANA2.vst3 back to /Library/Audio/Plug-Ins/VST3.
  4. Open Studio One, and then open any of the previously affected songs. They should now work.

Unfortunately, I don’t have the old version number handy. I’d need to dig that out from a Time Machine backup. Let me know if that info would be useful, and I can try to get it from one of those.

Thanks again for the help!


1 Like

Great ! :slight_smile:

Don’t bother to retrieve the old version number if you need to go through hassle like Time Machine backups :wink:

Thank you for your feedback and glad to read you sorted this out now :thumbsup:

1 Like