Unable to Install Kick 2!

Hi there :slight_smile: i just bought kick 2 and the installation won’t work properly. Basically what is happens, every file that is installing gets an: “Error opening file for writing”
It gives me an option to choose between Abort, Retry and Ignore. Please respond I’m really excited to try this plugin so i pray for help :pray:t2:

Sounds like maybe the installer hasn’t fully downloaded.

Try grabbing the installer from the site again then extract to a folder

Yep, like Phil mentioned, might be a corrupted download, try to download KICK 2 .zip archive again, we recommend to download the latest Betat V1 .1.5b from your My Account/My Downloads/Plugins area.

The Beta is fully functional and it’s the most up to date plug-in version at the moment and offers M1 Silicon support for Mac as well as VST 3 plug-in support for both Mac & PC.

The following help articles might be helpful as well :

How do I install KICK 2?

Manually Uninstall KICK 2

If you’re still running into issues then let us know your Operating System Name + Version Number as well as your DAW Name + Version Number, thank you.

You can also shoot an email to mailto:customerservice@sonicacademy.com

Hope this helps :wink:

Cheers !

1 Like

Hey, Hope you have a wonderful day :smiley: I am still running to the same problem.
Basically it happens to every file that is installing. (look on the screenshots)
My operation system: Windows 10 Pro, Version 21H1, 64-bit operating system, x64-based processor
Daw: Abelton Live 11 Suite
I tried downloading the Beta version and still same happened.
Thank you for your help :pray:

Have you extracted the zip file to a folder first?

Looks like you double clicked the zip and are trying to install without first extracting it.

You need to right click the file and “extract to folder”

i did extracted to a new folder that i created in my desktop and still same problem :frowning:
that you for such quick response :pray:

1- What archive manager are you using to extract the .zip archive ?

Try to use 7zip or WinRar if that’s not the case.

-You can extract on your desktop, the files are already in a self content folder, no need to create a new folder.

2- Do you right click on the .exe installer file and select “Run as Administrator” ?

Try to run the installer as Administrator.

3- Seems to be a permission issue to write/create files and folders in the ProgramData Windows directory.

  • Do you already have a “Sonic Academy” directory in “ProgramData” ?
  • If yes, and if you ONLY OWN KICK 2 ( don’t delete that folder if you have ANA 2 or other S.A plug-ins installed ) try to delete the “Sonic Academy” folder, reboot your PC, run KICK 2 installer as Administrator upon restart.

The “ProgramData” folder might be hidden by default, you can check this Microsoft help article to reveal files.

Been through this once or twice when updating UAD software, not sure why it happens, 3rd option did work for me, but I would suggest to check/try 1 & 2 before.

Hey Stef, First of all thank you for your support as always,
The first problem about installing the plugin on the computer is solved.
the issue was identifying “Program Data” file and then deleting the sonic academy files that was within.
for those who will bump into this problem, the solution is deleting the sonic academy files then reboot PC, after that install the plugin as administrator and it should flow.

For it isn’t over yet unfortunately…
After the plugin finally appeared on my Daw, i launched the plugin and then it instantly crashed. like exactly 5 seconds and the entire Daw crushes. not just the plugin.
My operation system: Windows 10 Pro, Version 21H1, 64-bit operating system, x64-based processor
Daw: Abelton Live 11 Suite

Much love for the help :pray:

hey there :smiley:
When i launch the plugin Kick 2, it crushes Ableton instantly.
My operation system: Windows 10 Pro, Version 21H1, 64-bit operating system, x64-based processor
Daw: Abelton Live 11 Suite
thank you for your help :slight_smile:

Sorry for the delayed reply.

Not 100% sure, but to me, it could be a corrupted KICK 2 installation following the previous install or something wrong with Ableton Live 11 installation itself are you up to date with latest version ? → Live 11.1.6

Here’s a step by step guide to a manual CLEAN INSTALL for KICK 2 ( sending this as well from support following your support ticket ).

Clean Install Procedure :

!! Please make sure to back up your User Presets if you have any before going through KICK 2 Clean install !!

You will also need to reinstall any DLC Presets Packs you may have after a manual uninstall.

  1. Close Any instances of KICK 2 and close your DAW.

  2. Remove the entire KICK 2 folder located here : C:/ProgramData/Sonic Academy ( The ProgramData folder might be hidden by default on Windows, you’ll need to Reveal Hidden Files & Folders )

  3. Remove the entire KICK 2 folder located here C:/Users/Your-Username/AppData/Roaming/Sonic Academy ( again, the AppData + subfolders might be hidden by default )

  4. Remove all KICK 2 plugins :

  • AAX : C:/Program Files/Common Files/Avid/Audio/Plug-Ins remove Kick2.aaxplugin

  • VST : C:/Program Files/VSTPlugins remove Kick 2 x64.dll ( an alternative installation path could be C:/Program Files/Steinberg/VSTPlugins depending of your install ).

  • VST3 : ( only installed with the Beta ) : C:/Program Files/Common Files/VST3 remove Kick 2 x64.vst3

  1. Upon restart, install the latest beta version KICK 2 V1.1.5b downloaded from your account My Account / My Downloads / Plugins

At this point if you have a User Preset backup, don’t try to restore it yet.

  1. Start your DAW with a NEW EMPTY project, not a previous session that was using KICK 2.

  2. Test if the issue is solved or not and please report back.