ANA 2 doesn't show up in Logic Pro drop down menu, but successfully validated

Hello! So I am experiencing a problem similar to this post

I’ve followed the instructions provided in this thread to a T, but to no avail.

I’ve recently upgraded from a 2017 MacBook Air to 2021 MacBook Pro.
My current specs are 14in MacBook Pro, Apple M1 Pro chip, macOS Ventura 13.0, 16gb ram.

I did a fresh set up and manually installed all my plug-ins instead of using Time Machine or the port features.
I rent/own ANA2 through Slate Digital’s All Access Pass, and have used it in many, many previous Logic sessions. Once all my plug-in installations were complete on my MacBook Pro, I tried opening my Logic Pro sessions which I created on my old laptop and ANA2 was the only plug-in that didn’t load.

It says it isn’t installed on my system, but it shows up in the plug-in manager and is successfully validated. I’ve confirmed that the ANA2.component is in my Mac’s Library/Audio/Components folder. I’ve tried reinstalling Logic, and re-installing ANA2 and rebooting various times in various orders (I did everything that the aforementioned thread said to do, besides receiving a special download link).

Unfortunately it just isn’t showing up. I use Studio One 6 and FL studio and ANA2 shows up in those programs just fine, no problems. ANA2 even shows up under AU plugins in FL Studio.

I’m not exactly sure what the problem is, nor the solution, so I could really use some help. I’ve seen a couple posts on reddit with similar issues so I’m probably not the only one. ANA2 is a critical part of nearly all my productions, so I can’t really ignore this problem with a sound mind.

Would love any help or advice, thank you!

  • What version of ANA 2 is installed on your Mac ?
  • have you downloaded and installed latest V2.5 from your account ?

I would advice to go through a manual Clean Install following the step by step guide below :

Clean Install Procedure :

!! Please make sure to back up your User Presets if you have any before going through the Clean Install :

1. Close Any instances of ANA 2 and close your DAW.

2. Remove the entire ANA 2 folder located in : /Library/Application Support/Sonic Academy
( this is the Main MacOS Library, not the user library )

3. Remove the entire ANA 2 folder located in : ~/Library/Application Support/Sonic Academy
( in your User Library this time !! )

4. Remove all ANA 2 plugins : ( Main MacOS Library ).

  • AAX : Macintosh HD/Library/Application Support/Avid/Audio/Plug-Ins remove ANA 2.aaxplugin

  • AU : Macintosh HD/Library/Audio/Plug-Ins/Components remove ANA 2.component

  • VST : Macintosh HD/Library/Audio/Plug-Ins/VST remove ANA 2.vst

  • VST3 : Macintosh HD/Library/Audio/Plug-Ins/VST3 remove ANA 2.vst3

5. Reboot your Mac.

6. Upon restart, download ANA 2 V2.5 and your License Key file from your account :

7. Expand the .zip archive and run the .pkg installer file from the MAC folder to install ANA 2.

8. Start your DAW with a New Empty Project, not a previous session that was using ANA 2.

9. Launch a new instance of ANA 2, you’ll be prompted by the welcome screen.

  • Click on “Register” and a new finder windows will open.
  • Browse to the location where you’ve previously saved your ANA2.keyfile.
  • Just select the file ( don’t try to open it ) and click on “Open” within the Finder window.

ANA 2 should be authorised after this.

Report back if this solves your issue or not, thanks :wink:

Hey! Thank you so much for your quick response and detailed list of instructions.

So, my ANA2 license is through Slate Digital’s All Access Pass, and I install it using their desktop app Slate Digital Connect. So I don’t have a license/key in my sonic academy account for it.
On the app Slate Digital Connect when I check ANA2 release notes, it says it has installed version 2.0.994…
but what’s strange is in Logic Pro’s plug-in manager, ANA2 shows up and is validated, but it says it is version 2.3.226.
Could this be part of the issue? Also I’m using Logic Pro 10.7.6 if that matters.

Regardless, it doesn’t show up in the drop down menu when I try to load it onto a new instrument track in a blank session.

I followed your instructions and removed the folders in MacOS and User library for app support and all the plug-in locations, rebooted, and reinstalled… but no change either. Tried booting Logic in Rosetta mode but didn’t help.

Sorry, was assuming you were using the perpetual license from Sonic Academy and not the Slate Digital version :wink:

So, in this case you can follow the Clean Install guide until step 6, then for step 6, download the ANA 2 V2.0.994 installer directly from the Slate Digital Installers page ( login required there ) and don’t use the “Connect” plugin manager app to reinstall ANA 2.

For activation, you need to be sure that you’ve got a ANA 2 License on iLok ( either a physical dongle or iLok Cloud ). You should refer to Slate Digital support for this.

Latest version for Slate Digital “All Access Pass” customers is V2.0.994(s) the latest V2.5 release is not ready yet at their end, I believe there’s still some work in progress to update their own plug-in skins and presets before they got this ready.

The installers page is available here : Slate Digital

All of that said, there’s no known issue with ANA 2 V2.0.994(s) from Slate Digital and Logic Pro X 10.7.6, unless it’s something we’re not yet aware of with Ventura + Latest version of Logic Pro X.

If you keep having issue after the Clean Install with V2.0.994(s) and checking iLok authorization, then please shoot an email to

1 Like

THANK YOU. I was having this same problem after upgrading from my 2014 Mac Mini to a new Mac Studio M1. The key is to remove all of the old files, and then do a NEW Logic project in order to properly register ANA 2.

But even after that, all was not perfect yet. The old ANA 2 track in my project still refused to load. The fix was to add a new software instrument track using ANA 2, and drag the content from the old track to the new. Hopefully you have your track properly labeled with the patch you used, because the original track will never open. :confused:

1 Like

Welcome to the forums and thanks for your feedback and comment ! :sunglasses:

Yes, totally makes sense to open a new LPX project for activation and make sure there’s no older plugins files installed on your device :+1:

Not sure why the older track is not reopening at all inside LPX, there was some issue with a specific previous version causing the settings not be correctly recalled, but would expect LPX to load the track and ANA 2 at least.

If the track loads but there’s no plugin GUI displayed inside LPX, it could also be an installation issue and the plugin not finding the GUI folder. So yes, Clean Install is recommended then. Just keep in mind you need to backup User Presets and that you will need to reinstall any DLC Presets packs you might have.