Cant send midi to another midi channel in live 11

Hi there Neil,

Think you can use an External Midi Instrument channel inside Live but there might be additional steps on your device to setup Midi Out.

Don’t own the hardware, so can’t verify this info but found this on the web :

Setup Parameter Settings (SEQ SETUP)

  1. Press the [NOTE] button and [GATE] button to make them light.

  2. Use the [1]–[3] buttons to select a parameter, and use the [VALUE] knob to edit the parameter’s value.

The display indicates the value.

Button Parameter Value/Explanation

[1] Destination
Specifies the output destination of the step sequencer.
Int: Internal, : External device, bot: Both internal and external device

[2] Sync
Specifies the clock to which the step sequencer is synchronized.
Int: Internal, Nid: MIDI IN, USb: USB MIDI, trg: TRIGGER IN

[3] Key Trigger
Specifies whether the step sequencer is controlled by key trigger.
OFF: Not controlled, On: Controlled, trn: Controlled according to the transpose

  1. To save the edited settings, perform the Pattern Write operation.

Edit : seems to be related to the sequencer though.

There’s a Roland Forum at the link below, you might be more lucky to get the right answer there maybe.

Thanks for your response.
My problem isn’t really with the synth itself or the setup its why i dont have the option on the midi channel to send midi in live to another midi channel only the option to send audio to and no option to send midi to.

when i try and use the external instrument option in live and press a key on the synth it just feedsback on itself and clips

You can set the MIDI source in the MIDI FROM on the destination track where you want to receive MIDI.

i.e : here there’s ANA 2 on the 1st Midi Channel, on the 2nd One the “MIDI FROM” slot is set to ANA 2 and the Monitoring Option is set to “IN”, then the track is Record Armed to record the MIDI OUT from ANA 2 channel.

Screenshot 2023-03-14 at 13.55.31
Screenshot 2023-03-14 at 13.55.54

i have just setup my live session exactly the way you’ve show in the example with anna 2 on the first channel but as before i don’t get the option to send midi to on the second channel only send audio to as an option

A screenshot would help :wink:

You don’t set “Midi to” but “Midi From” on the 2nd Midi Track ( the destination track ).

1 - Insert ANA 2 on the 1st Midi Track.

2 - Create a 2nd Midi Track and click on the “MIDI From” slot → you’ll see the label “MIDI From” in Session Mode view only ( switch with TAB ) in the Arrangement View it’s the 1st slot.

3 - When clicking on the “MIDI From” slot arrow, you should be presented with ANA 2 as the MIDI source. Select this and turn Monitoring to “IN” instead of “Auto”, arm the track for recording.

Screenshot 2023-03-14 at 13.55.31

any idea why this wont work for me seemes to be what you have suggested bust wont work for me

My example was just to illustrate how to route MIDI from one Midi Track to another in general.

Seems to be what you’ve done between Track 35 ( ANA 2 ) and Track 36.

So if you put some Midi Clip on Track 35 and hit Record, you’ll get the Midi notes Out from Track 35 recorded into Track 36.

Now if you’re trying to play ANA 2 or another Midi Instrument from your Roland SE-02 keyboard, you don’t need this routing, you should be able to select the Midi Input Source directly from the “MIDI From” slot of the Instrument you’d like to play.

So I believe you just need Track 35 with ANA 2 and select where from this Track should receive MIDI input, your Roland device should be listed in the “Midi From” sources list.

For example here I have a Push 2 and NI Maschine controller, I can select the device I want to send Midi to ANA 2

You may need to take a look at your Live Preferences MIDI setting as well, can’t tell if there’s an extra step to setup your Roland Device as a Midi input since I don’t own this device.

You should ask this on the Roland forum if the above is not working for you.

Screenshot 2023-03-14 at 15.30.50

Just a though… have you enabled the Se02 as a midi device in Ableton preferences?

1 Like

Yep, defo check your Live’s Preference Midi settings as well.

Not sure if you can setup the Roland Se02 as a Control Surface with Live, but you should enable Midi In port for it at least.

thanks for your help ive done all of the above but all i want to do is automate parameter’s on the hardware of the se02 after ive inputted the midi. im also using the vst se02 in conjunction.
Ill go on the roland forum again and see if i cant work this out.
Cheers guys

If you’re using the VST for Se02 as well, then I guess that’s why you’re getting feedback maybe.

There’s 2 different things going on : just the device as a Midi trigger input and the Roland Boutique VST as an instrument.

Automation should be available on the VST device itself inside Live.

Illustrating this with ANA 2 here, if you click on the Top Left arrow, it will expand the Se02 VST automation parameters, then you can click on “Configure” and try to move knobs on your synth, or it might already be all assigned. Then your reveal automation lines inside Live by pressing ‘A’ on your computer keyboard.

But yep, not sure about the Roland Boutique devices implementation inside Live, so you might be more lucky asking the question on their forums :wink:


Screenshot 2023-03-14 at 16.23.47

thanks ill keep going. you have been very helpful im sure ill get to the bottom of it.
actually the weirdest thing is that live doesn’t give me the option the send midi from one channel to another just to send audio

If a midi track has a vst on it it can’t send midi… it kind of makes it an audio track… make sure you make a new midi track and there’s no vst instrument on it.

1 Like

ok thanks that could be the problem.
PEEEACE :smiley:

1 Like

That was the point of Post 8 actually :sweat_smile:

But OK, I know I have a tendency to over complicate things - LOL :rofl: :joy:

Cheers :sunglasses:

Hi guys I’ve now worked out why i couldn’t sent midi from one channel to another. its because i had a midi default channel set up with an EQ and a utility on it but if i cant put an eq on a midi channel how do i eq midi or without a utility on it how do i manage my gain staging. i don’t think this was a problem for me before. the option to send midi disappears when i add these plugin
any advise on this would be much appreciated.

Hi again Neil

Yeah, so that’s actually the normal behavior inside Live 11 as already mentioned by Phil and I.

01 - If you have an Empty Midi Track, you will see the Option ‘MIDI To’ :

01- Empty Midi Track

02- As soon as you insert a Device on a Midi track, this option vanished and turns to “Audio To” :

02-Midi track with a Device

03- So you need to Create a New Midi Track and get the “MIDI From” this other channel to complete the MIDI Routing :

03-New Midi Track

Midi is only a data communication protocol It only sends information about what notes you are playing and the controller messages. there is no actual audio in a midi signal.

The Audio from the SE02 will come back through and audio channel. either from the hardware outputs connected to a soundcard or through the usb.

So you need one midi channel to comunicate with the se02 and an audio channel to route the signal

Ableton has an instrument devices called “external instrument” which sits on a midi channel and lets you do both the midi and audio stuff on one channel.