Kick 2 1.1.5 and OSX Sierra

Hi folks,

I tried all the fixes in this thread on the off chance that something odd was happening with Kick 2 for my particular situation. I am running Logic Pro X on OSX Sierra, and I get an error after installing before I can even load the plugin… “Compatibility - couldn’t be opened.” Any thoughts on how to fix if none of the solutions in that thread worked for me?

When I “reset and rescan selection” this is the error I get.

validating Audio Unit Kick 2 by Sonic Academy:

AU Validation Tool
Version: 1.6.1a1 
Copyright 2003-2013, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options


Manufacturer String: Sonic Academy
AudioUnit Name: Kick 2
Component Version: 1.1.5 (0x10105)

    • PASS

FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF

validation result: couldn’t be opened

Have you tried to Reset your AU Plugins Caches as well ? Seem it was this step that fixed the issue for this other user.

You are referring to these steps you outlined? Then yes I tried that.

1- Remove the
2- Remove the AudioUnitCache
3- Clean your Caches by deleting the MacOS-HDD/Library/Caches

Yes, was referring to this.

So if that didn’t work the issue is different then. Is Logic up to date on your Mac ?
( I believe latest version available for MacOS Sierra would be 10.4.8 → not sure, it is for High Sierra. )

From memory, I recon there were past issues for which the only solution was to upgrade MacOS.

Shoot an email at support and we’ll have a look into this :

That might be it. Sierra can run up to 10.4.4, which is what I have. I’ll try a system upgrade to High Sierra and see what happens.

Let us know if you’re still having issue after upgrading to MacOS High Sierra, hopefully it will solve this.

For info, latest High Sierra update will be 10.13.6 ( after you’ve installed all security updates ) and latest available Logic version for High Sierra is 10.4.8 ).

Still running a device with those specs here at my end and KICK 2 V1.1.5 and other S.A plugins are working fine on this setup.

Ok, so I actually upgraded to OSX Catalina and I didn’t even need to update Logic. It just loaded fine and works. Thank you for your help!

1 Like

Thank you for your update and feedback on this, much appreciated ! :wink:

Happy to read that upgrading to Catalina solved the issue at your end :+1: