Kick 2 issue with MacOS Catalina & Logic Pro X 10.5

When I press spacebar (play/pause) or click the button which takes the cursor back to 0 (start) in Logic Pro X, the click presets are wiped, and an asterisk appears next to the preset name.
It means have to reset the preset everytime I hit spacebar to get the click settings back.
Any ideas how to fix?

Hi there @ryanbingram

Are you having an issue with KICK 2 inside Logic Pro X ?? That’s what I understand since you’re talking about “click” settings but not sure since you’re not mentioning any plugin name.

We need basic information in order to understand & try to help :wink:

Thank you to update your post with the followings :

  • MacOS name + version number
  • Logic Pro X version number
  • Kick 2 Plugin version number

Yes, I forgot to mention it was in Kick 2

Catalina 10.15.4

Logic Pro X 10.5

KICK 2 (latest version)

Hi again @ryanbingram

Thanks for the update & info.

Could you please try the following to ensure that Kick 2 GUI is correctly initialized : go to settings and from the settings panel, try to select a different skin as well different GUI size and see if that makes any difference.

If that doesn’t make any change, then I suggest you to try a clean uninstall/reinstall procedure following the following support guide line to ensure if this could be a bug or not. No one reported such issue so far, so it looks kind of weird.


This has been tested by S.A team and they are unable to reproduce this issue with Kick 2 inside latest Logic Pro X 10.5 under MacOS Catalina. So it’s doesn’t look like this is a bug from Kick 2. Unless you have custom key mapping for the space bar & the rewind button inside Logic, I can’t see why pressing those will have any effect on Kick 2. Make sure that those keys command are set as their default settings and also make sure that you don’t have any automation lanes for Kick 2 on your channel.

BTW, there’s a very recent MacOS Catalina 10.15.5 update available from Apple, you might want to upgrade to this latest release as well.

Let us know if the suggested solutions solved your issue, the manual uninstall procedure ( previous post ) is not that complex and doesn’t take too much time, just make sure to save your user presets if you have any.

Hi, I followed the clean uninstall instructions and it worked, but now the same glitch is happening. I press spacebar which is the same as play, and it resets the second click length to 0, even if I save the preset.

Have you installed this latest Catalina update as well like I mentioned before ?
You should then be using MacOS Catalina 10.5.5 → Logic Pro X 10.5 → Kick 2 v1.4

Just to clarify and make sure where we’re standing with versions numbers, thanks.

  • Also, I’ve seen that you created a new technical Support topic for this, that wasn’t necessary BTW.
    In the new topic you’re mentioning that you attached a clip : where is this ?? Nothing on the post itself.

Check your 2nd topic here :

Continuing the discussion from Kick2 glitch in logic

Hi Ryan

This definitely sounds like you have assigned the CLICK 2 length to a MIDI Learn Parameter

Right click on the length of click 2 and remove the midi learn assigned here

Hi there @ryanbingram

Any update on this one ??