Kick 2 License Doesn't "Take"


I opened a Zendesk ticket at your support address but I have not gotten a response so far. (Ticket 10502)

I recently installed Kick 2 on a new machine. However, Kick 2 reverts back to Evaluation Mode after a few seconds.

I attempted to revoke my machine using my online account and reinstall but now it won’t let me do that for 30 days.

Inside the plugin, when I choose to connect my account, I get a prompt telling me my machine is already registered and I need to revoke it using the site (which I cannot do).

When I attempt to supply my keyfile using the Offline Activation mode, it tells me it successfully registers but after a short while it reverts to Evaluation Mode and gives me a hiss until I re-supply the keyfile, which repeats the whole issue I just described.

I’ve attempted uninstalling and reinstalling. I also attempted to uninstall using IOBIT uninstaller, which deleted my entire VST2 folder, forcing me to spend a half-hour reinstalling every plugin that was inside it. :frowning:

Please help. This is the one major roadblock I have to sending my album off to get mastered.

HI there @Plastic_Mohawk

On how many machines are you trying to install & authorize your Kick 2 Plugin ?

You should be able to install on 2 machines only and as for revoke/authorize machine there’s also a limitation of 2 devices per month if I’m not mistaking.

Reading what you write about IOBIT I suppose all of this is happening on Windows, right ?

Thanks to specify your Windows version as well as the DAW your using and especially are your running a 64 or 32 bit DAW. Once you’ve downloaded the .zip archive from your S.A account/downloads/Plugins and extracted it, you have to make sure to run the matching installer from the PC folder : there’s a KICK 2 v1.1.1 64 bit.exe for the 64bit version of the plugin, the KICK 2 v1.1.1.exe installer is for 32bit Daws/system only.

At this point you seem to have reach the per month limitation for revoking devices, so that indeed will need to be sort out by support, I’m just moderating the forums here. I’ve seen your second post asking about support ignoring you, I have no elements on my end about your support ticket, so I don’t know when it was opened and if you’are in a reasonable time frame for a reply or not. What I will do is to direct message the support team with your support ticket number and I’m sure they will get back to you and sort this issue for you.

I’ve seen your other post telling that support is ignoring you, I will mark it as “solved for now” and refer to this current post, thank you to use this current topic for further update.

Very sorry for the inconvenient and any response delay but I’m sure support will sort this out for you, but first thing to clarify is the number of machines you’re trying to install KICK 2 on. Thank you.

Hi there,

Thanks for getting back to me.

I currently have only one active machine I am attempting to install/run on. This is a new machine to replace me earlier one which bricked due to a motherboard issue.

Yes, it’s Windows 10.

The reason my account history shows me revoking the same machine over and over is because that is what I was prompted to do by the plugin while attempting to sort out the license issue on my own. The first revoke you see is that bricked computer which I’m assuming is apparent due to that serial number being different from the newer revokes, where I see those are the same.

While attempting the online activation mode currently, it is still telling me to revoke my license and directing me to my account page which informs me I cannot revoke again for 30 days.

This leaves me with only the keyfile option. When I supply the keyfile obtained from my account page, the plugin tells me the activation failed and I should contact support, which I have done both via Zendesk and also attempted here.

It also occurred to me a few hours ago that the Ableton projects which exhibit the issue may have been running an older version of Kick 2 which seems to have received an update last winter (I missed that update at the time where now I am installing the updated version on the fresh machine which is leading to the issue being exhibited in those older projects which were created on that older machine and ported over to this one. I can test this later today when I get out of work by attempting to recreate the issue in a fresh project using a reset Ableton.

Thanks for your help.

Update : reading this again, and have you tried Online registration & auth. using your S.A credentials before trying the offline activation ? Might be a point too next to the number of devices.

Note that I did somehow end up with two keyfiles - one keyfile indeed tells me the activation failed while the other tells me it succeeds but later reverts to evaluation mode. I can’t remember where that other keyfile came from; I assume I got it during one of the many reinstall attempts I’ve been doing since I first noticed the issue.

Yes, I am running Windows 10 64 bit and I am definitely installing the 64 bit version of Kick 2.

Yes, that’s what I meant by:

OK, understood the different step you took, so that’s clear for the online procedure, and the number of installation, thank you. I can’t see anything about your attempts and licensing BTW ( again just moderating here ) but that’s an update for support anyway.

Also when you’re writing about license key, do you mean the key file in your account ? Because that won’t work with the latest v1.1. version of Kick 2, that key file is only for previous version using the old authorization method.

IMO it seems like just a loop because of the revoking limitation, support should fix this for you, I’ve seen that someone replied to your 2nd post so the request is handled by them now IMO.

I’ll re-check this when I get home in a short while, but I’m assuming the “License Key” download button I see underneath the “Download v.1.1.1” button is the one I’m supposed to be using.

Somehow, I ended up with two keyfiles, which could not have come from the old computer running the old Kick 2, because I did not copy anything from that old computer before it failed (I had been backing up my Ableton projects via cloud storage which is why I have those on my new computer from the old one). One of those keyfiles gives me a success, which reverts to evaluation mode after a few moments, and I am able to use that to repeat that whole process; the other keyfile flat out tells me it fails to authorize and I should contact support.

As mentioned I will re-test a few things when I get home this evening and post a more detailed step-by-step for walkthrough purposes.

Thanks again!

No, as mentioned before, though I understand that this can be confusing, this License Key will only work with previous v1.05 version, totally useless with the new v1.1.1

Some guide lines here : Kick 2 v1.1 BETA - Please Read

Support is aware of it now, so they will sort it out for you, no worries.

Hope that helps and sorry for the delayed answer again :wink:


I am home and can provide this step-by-step walkthrough of my most recent attempt.

1.) Removed Preferences.cfg from C:\Users.…\AppData\Roaming\Ableton\Live 10.1\Preferences to reset Live as per:

2.) Uninstall Kick 2 64 bit via Windows Apps and Programs

3.)Delete Sonic Academy folder from C:\Users.…\AppData\Roaming

4.) Start Ableton 10.1 (new default project)

5.) Close Ableton 10.1

6.) Download Kick 2 from Sign Up

7.) Extract Sonic Academy KICK 2 - V1.1.1 and run KICK 2 v1.1.1 64 bit installer, setting Destination Folder to: C:\Program Files (x86)\VSTPlugins\

8.) Start Ableton 10.1 (new default project), setting VST2 Custom Folder to C:\Program Files (x86)\VSTPlugins, which locates Kick 2 x64

9.) Load Kick 2 into a new audio track. Registration modal pops up.

10.) Click “Connect to your account…” Enter username and password. Message: This device has already been registered - please revoke any devices at the link below

10a.) Note I can no longer revoke devices as per limitation set by Sonic Academy

11.) Click "Offline Registration, following the 4 steps

11a.) On Step 2, I get the following message from the Offline Registration page: “The form contains 1 error
License registration failed, you aren’t allowed to register additional devices”

12.) I am left with no further alternatives at this point.

1 Like

Thank you for the clear step by step description, definitely looks like the revoke devices attempts reached. Needs to be cleared by support. Allow them some time to work on your account and try to avoid new attempt for now on your end, it’s night time here anyway. Will ask them about this tomorrow again and keep you updated here, thank you.

Edit : forgot to mention, you should be able to see you devices management historical using this link once logged in on S.A website Sign Up

Just for info, you’ve probably been there already :slight_smile:

Thanks - much appreciated. Also can you ask them to please do something about this? :slight_smile:

Haha yes I’ve visited that page a bazillion times already but it looks like there was a new revoke about half an hour ago which I’m assuming is from your support? :slight_smile:
So should I continue to wait to hear back from support or can I go ahead with another reattempt?

I will do, though there might be a reason why the older license file is still available on the download page + there’s a red disclaimer warning users about that. Here is an actual screenshot from Firefox just made now :

Yeah I discovered that page after we started talking in this thread. The page in my screenshot is from the “My Account” main page which is the first page you come to when you log into your account and click “My Account”

i.e. not buried three links deep like yours :wink:


How many device(s) are showing up active in there right now ?
If only one appears in the list, you could try a new activation but if it’s matching again your older PC ( defect Motherboard ) like it seemed to have done in first place, you may fall in the same problem again. I can’t tell what kind of ID they use to identify your device, I really don’t know about that, but it could be your Hard Drive or Ethernet card that was also used with your first configuration, therefore making a problem to distinct your new PC from the old one. So if you decide to try and if that doesn’t work, you’ll need to ask that they revoke all your devices.

Suggest to wait for tomorrow :wink:

This screenshot is what I see now. Note it’s different from when we first started talking here as Sonic Academy wouldn’t let me revoke the top one due to the limitation imposed.

This computer is completely different from that computer and that computer was the first one I revoked when this whole thing started. So I’m not sure how my hardware could be matching since that old computer is currently in the recycle bin. (Note it is possible to revoke one computer by logging into the account using a different computer)

So I’m assuming based on this screenshot that all my licenses are currently revoked which seems like a good sign as progress seems like it’s being made but I’m just not going to touch anything at this point and go have a beer to reduce my stress levels from all this with the hopes it gets resolved tomorrow :slight_smile:

Have a good night and thanks again for the help!

Moderator edit : Removed the screen shot displaying ID, the forums are on public access for reading only, we don’t need this info here :slight_smile:

Wise strategy IMO, it’s late here but probably gonna have one too ! Cheers :beers:

In any case it will get sort out by support, catching up tomorrow and wishing you a good night ( evening ? ) too.

'Till tomorrow then ! :wink:

Hi again @Plastic_Mohawk

You should have been updated by support, looks like they revoke all devices for you so give it a new try today, remember there’s no license involved anymore, just follow this procedure

If it doesn’t work again then it might be something more tricky, informed back support then but hopefully this should be working now.