Kick 2 shows up as an empty window

Just upgraded to OS X Big Sur and now Kick 2 is showing up as an empty gray window, seems like the interface is not rendering.

I’m running Ableton Live Suite on a MacBook Pro (2018) with 3 screens (1 from the laptop and 2 large monitors) using DisplayLink Manager.

Formerly I was running OS X Mojave and everything was working fine.

I tried a fix that was suggested elsewhere on this forum (link below) but after doing that the fans of the MacBook seems to go crazy and makes lots of noise + one of both large monitors stopped working.

Any other idea’s how to fix this ? Or may we expect an update soon ?

Thx in advance,

Try a clean install first : that is Manual uninstall + Reboot + new Install with a recent installer downloaded from your user account. Latest version of KICK 2 is v1.1.4

You’ll find the guide to follow for the manual uninstall here : Manually Uninstall KICK 2

If this is not solving your issue, then please report back with details on your setup ( MacOS version number, computer Specs, DAW name + version ) and a screenshot showing what you mean by “empty window”.

You’re also having a rather specific multiple displays configuration, I understand you’ve reported it was working well before with the same setup, so hopefully a clean install will work, but this part of your setup might come into play as well ).

Hi Stéphane, thanx for your fast reply.

Did everything you suggested (also removed the ANA-files since there is the same problem with that plug-in) but unfortunately manually uninstall, reboot and re-install fresh downloaded installers won’t solve the problem.

I’ll upload screenshots from the Kick 2 and ANA windows, but as you can see they’re both just empty windows.

My system config:
MacBook pro (15 inch, 2018)
Processor 2,9 Ghz 6-Core Intel Core i9
Memory 32 GB 2400 Mhz DDR4
Graphics Radeon Pro Vega 20 4 GB

I’m using a 3 monitors setup, 1 from the MacBook and 2 external large displays connected using DisplayLink Manager.

Plug-ins are both running inside Ableton Live 11 Suite (11.0.12 Build: 2021-11-04_b232c5df34)

Meanwhile I found out that when I quit the DisplayLink Manager app both plugins (ANA & Kick 2) are doing well but 1 of the large monitors stops working. So, seems it’s probably the OS X Big Sur with DisplayLink Manager app combo that messes up everything. Before my upgrade to OS X Big Sur I was running OS X Mojave, I didn’t need the DisplayLink Manager and everything was working fine with this 3-monitors setup.

Probably a clean install with Mojave will solve the troubles but since I’m a freelance graphic designer for living that’s not a solution for me at this moment.


Hi Herman,

Hmm yes, looks very much this has to do with Display Link manager under Big Sur, there’s no settings in both plug-ins to modify the user interface display and there’s also no options inside Ableton Live 11 beside choosing dual displays.

Have you reported this and check with Synaptics support + forums already ?

I found this page here : Troubleshooting: macOS – DisplayLink Support

I will ask more about this on S.A end, but it’s definitely not a standard way to use the plug-ins I’m afraid, can’t think about settings to change in order to help with this at first.

Hi Stéphane,
I’ve indeed also start a conversation with the manufacturer of DisplayLink Manager and sent them a report made by the DisplayLink Information app they provide to see what’s going wrong but got no satisfying answer by them till now.
If we’ll find a way to solve this I surely let you know in this thread.

Thx again for your support,
Herman Belgy

1 Like

Hey dear,

So i’ve tried manually un-installing, and re-installing. Both Kick 2 v1.1.4 & Ableton live 11 suite.
Im Using M1 macbook pro Version : Big Sur 11.6.
The VST just wouldn’t show up in ableton, regardless how many times i refresh.

Any help would be appreciated.

1. Check your version of Live and if you start the DAW in Native ARM mode or Rosetta 2 Compatibility Mode.

Live 11.1 ( available through the beta and also full release now ) can run either in M1 Native or Compatibility modes ( depending of the version you’ve downloaded & installed from Ableton ). Locate Live App icon in your applications folder and right click on it and select “Get Info” and you will see the options to run Live in the desired mode.

2. If you are running Live 11.1 in Native ARM mode, then you need to install KICK 2 1.1.5 beta, if you are using KICK 2 v1.1.4 it won’t show up inside Live since it’s not M1 ready.

The beta is available for download in your account :

Hey dear,

I’d like to thank you for your quick response.
I downloaded the beta version & it seems to work fine now, Thanks!
Outta curiosity can you please confirm if there are any limitations in using the beta version?

The beta is fully functional :wink:

However, it’s a beta version, so if you find anything not working or have issues, then please let us know.

There’s a Kick Synth dedicated topic on the forums here KICK Synth - Sonic Academy Forums
or you can also shoot an email to support :


Hi again Herman,

Following back on this, have you tried to install the latest beta version v1.1.5b to check if you’re still getting the same issue with this new version ?

Not 100% sure if that will solve your issue since you still have a specific usage because of DisplayLink Manager, but Open GL support could also be causing issue with version 1.1.4, this was removed in the latest beta following Apple recommendation and the drop of Open GL support on the more recent MacOS versions.

There’s a way to disable Open GL as well in version 1.1.4, but this involves editing and modifying your Kick 2.settings file in your User Library, but that can easily be done using any text file editor.

  1. From the Finder Menu, select the Option GO → Go To Folder…
  2. Copy paste this in the popup finder window : ~/Library/Application Support/Sonic Academy/Kick 2/

Then it’s just a matter of editing the Kick 2.settings file with text edit and copy/paste the following line before the last line and save your change.

VALUE name=“noopengl” val=“1”/

This needs to be added just before the line /PROPERTIES (that one should always be the last)

All lines should be inserted between < > signs !! ( see example pic below ) I can’t add this here since it’s interpreted as code by the forums post editor, so it won’t show up.

The beta doesn’t need this and is fully functional, it also brings VST 3 and M1 native support to KICK 2, but should you prefer to keep using v1.1.4 for now until the next stable release, then you can try the above workaround with v1.1.4.


Just changed the Kick2.settings files as explained in your message and the Kick2 window looks and works like it’s supposed to do.

Thx a lot !!!

1 Like

Thanks for your reply :wink:

Great news ! Happy to read that it’s now working with this workaround :smiley:

So yes, it was an issue with OpenGL in the end. That will be removed in the future versions of KICK 2 since it’s now depreciated for recent version of MacOS, but for now this workaround is the solution.