Repeated Preset Updating in ANA 2

Whenever I choose any preset in ANA 2 I get a pop-up asking to update my presets. Even after I update it continues to appear. Why is this happening anyone?


That should only happens once, which OS are you using MAC or WIN ? Are you up to date with latest version of ANA 2 ( v2.094 ) → you can download the latest from your account here Sign Up ( be sure to be logged in ) and try a new install. Maybe something went wrong with your previous installation.

So, i have the same problem. But i updated now to the latest version, But the problem is not solved by the update. Any idea?

Hey there @LichtBildGestalter

Have you tried the manual uninstall procedure from the support page and then reboot your Mac or PC and perform a brand new installation after downloading the latest version ( v2.0.97) .

The all procedure only takes a few minutes following the steps matching your OS in the support thread.

Just make sure to backup your User Presets if you have any ( you can just make a copy of the folder ).

You’ll find the manual uninstall procedure here.

Hi, thank you for your support
The manual uninstall and e new installation solved the problem, but unfortunately not quite.
But at the next, i restored the backup of my User Presets and the User\Sampler Osc, the problem occurs again.
So i think there is any problem with my User Files. What can i do?

How did you restore your presets ? Have you moved your entire backup folders and replace / overwrite the default folders created by the new install or did you just copy your presets & samples in those new folders ?

Also what’s your files structure ? Did you add or create custom folders or are you using the default one ?
Some screen shots could help to check this.

→ Here’s what you should have by default :

  • For the User Sampler OSC files :

1- Open ANA 2 inside your DAW and click on the “waveform” in the Sampler OSC
2- Click on the sub-folder display icon to reveal them.
3- The default structure is User/Imported → Your_Sample_name.wav

  • For the User Presets files :

1- From ANA 2 GUI, click on the top MENU and select Open User Preset Folder to reveal the User folder in finder where your presets should be located. Once you expand the view in finder, you should see the full path for your user presets.

I’ll try to explain how you can easily revert to this default configuration without having to uninstall / reinstall ANA 2 again in a next post but some screen shots of your own configuration could help :wink:

Also what’s your DAW and MacOS version ?


the following folders i used for restore:

C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Sampler Osc
C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Main Osc
C:\ProgramData\Sonic Academy\ANA 2\Presets\Sound Presets\User

the error occurs independently of the DAW (Ableton Live 10), but also when I use a VST host, such as: NanoVST (Tone2) or VSThost (H.Seib). OS is Win 8.1
I do not install any soundpack after new instalation


Hi again,

Hmm, I assumed that you were using MacOS but I can read that you’re on a PC & Windows now :blush:

Your user files should be in the following locations :

  • User Sampler Osc audio files →

C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Sampler Osc\Imported

  • User Sound Presets →

C:\ProgramData\Sonic Academy\ANA 2\Presets\Sound Presets\User\User Presets

  • and inside the Waves\User\Main Osc folder you should have 3 sub-folders : 3D Wavetables, Analog, Digital → those sub-folders should only contain Wavetable files BTW.

Here’s the full path for those 3 :

C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Main Osc\3D Wavetables

C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Main Osc\Analog

C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Main Osc\Digital

yes i know…

the “\Waves\User\Main Osc\3D Wavetables” and the “\Waves\User\Main Osc\Analog” are empty
in “\Waves\User\Main Osc\Digital” are 5 files

The most of my files are in:
C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Sampler Osc
In the Sample Osc are 5 subfolders, but nothing changed since 2019
Only in “Waves\User\Sampler Osc\Imported” are 3 new wav-files (of 68 files at all)

may be that is the problem? Any Idea?

If it worked fine after the manual uninstall / install before you overwrite your User folders, then yes, it could be that something is wrong with your files structure.

The paths mentioned in my previous post is what you have after a default installation, I think you should try to get back to this default file structure, try the following.

→ Backup and MOVE those 5 files you have inside “Waves\User\Main Osc\Digital” and keep it empty like the 2 other folders “3D Wavetables” and “Analog”.

→ Backup and MOVE all files & folders you have inside the “Sampler Osc”, that means all your 5 folders + the “Imported” folder.

→ Then make sure to backup your User Presets ( the .SndPr files ) by moving the entire “User” folder located here :

 "C:\ProgramData\Sonic Academy\ANA 2\Presets\Sound Presets\ ---> User <---
  • After you’ve backed up those files go to the following location :

      "C:\Users\Your_User_Name\AppData\Roaming\Sonic Academy\ANA 2"

You should find a “ANA 2.settings” file in there → DELETE it.

  • Now go back to

      "C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Sampler Osc\"

and create a new “Imported” sub-folder inside “Sampler Osc”

  • Restart Ableton Live & launch an instance of ANA 2

  • Your “User” + “User Presets” folders should now have been recreated automatically in

      "C:\ProgramData\Sonic Academy\ANA 2\Presets\Sound Presets\User\User Presets"

Now instead of overwriting the new default folders, ONLY COPY the audio files and presets from your Desktop Backup to their respective locations :

– > All backed-up Preset_Name.SndPr files should be copied inside :

  "C:\ProgramData\Sonic Academy\ANA 2\Presets\Sound Presets\User\User Presets" 

– > All backed-up Sample_Name.wav files should be copied inside :

  "C:\ProgramData\Sonic Academy\ANA 2\Waves\User\Sampler Osc\Imported"

Don’t move back or copy those 5 files that were in the" Waves/Digital" just yet, and also don’t move back those 5 sub-folders you had in the “Sampler Osc” location for now.

Try if it works and if you don’t have the “refresh” issue anymore.

Then you can try to add back those 5 folders and 5 extra files you had one at a time to troubleshoot if they are causing the problem.

thank you so much for your support!!! :heart_eyes: it solved the problem :thumbsup:
I found one (defect?) user preset file, only these file is causes the error. :unamused:
Now i have restored alle other user files, presets, waves files and so and it works fine. I can do without the one preset, there is always a little shrinkage. Many, many thanks, that was so helpfully. :clap:
ANA 2 is one of my favourite synth applications, it appears in almost every song of mine. I am so happy.
Have a nice day and a fantastic weekend
and stay healthy
greetings from lower saxony :wave:

1 Like


Happy to read that it’s now working :wink:

Hmm, yes … I can imagine the feeling :unamused:

it’s often little things that cause problems and they are the most difficult to find out, but in the end it worth the time & effort when you’ve got things working again :wink:

Thanks for the kinds words and have a great weekend as well :thumbsup:

Cheers !

just to chirp in here - if the preset is Write locked for some reason (back and forth through dropbox / various computers) then ANA 2 probably isn’t doing its job.
Check the permissions on the offending file and make sure admin and user can read/write to it

1 Like