Changing the "Licensed to ... " name on ANA2 (?)

I’m looking for a way to change the license name on ANA2, seems there’s no way to do that manually?
Could find two related threads here, one is for Kick2 here >> How to change the Kick 2 License name?

Since I own Kick2 as well and had the exact same naming there I tried that method for Kick2 first. Followed the steps from the thread, except for changing my user account because that already is on the name I want to have on Kick2/ANA2. Guess I changed the account name shortly afterwards purchasing years ago. I revoked the license in the account and re-activated Kick2 again and now my user account name is displayed on Kick2. So all good with Kick2.

But I can’t find a way for ANA. There’s no “Revoke Device” option in the account for ANA2, which might be the main issue.
What I tried was to delete the “ANA2.keyfile” under …\AppData\Roaming … (Windows10) so it’s not registered anymore. Downloaded a fresh License Key from the account and registered again, but it still shows the old user name. I’m guessing the reason is that the “old” license won’t really be deleted (no Revoke Device), so it keeps displaying the name from the original licensing (?).

Could only find one thread on the topic for ANA2, this one >> Is there a way I can change the name on the License?
It’s mentioning contacting support, but the thread is already three years old so I’m not sure if things have changed in the meantime.

Should I ask support or is there any other way I might be overlooking?


Hi there

Yes, this can only be updated on SA end.

So you will need to send an email to for this.

Include your account Username + email address in your message for support :wink:

For Info SA team : @bryan_spence

1 Like

Thanks, E-Mail sent, guess it’s in the works.

Question, different topic but not really worthy opening a thread at this point:
@Tekalight are you a bit familiar with the GUI design of ANA?
I started working on a skin for ANA and there’s a ton of unclear things. TBH this is probably the most untidy GUI I’ve seen :rofl:
Because of that I would’ve preferred using a different skin than the factory GUIs as foundation, but pretty much all other skins aren’t up to date and got their own glitches. So I need to use the factory as basis.

Ok here’s one example for things that aren’t right:
The Filter Mix knobs on OSC 1-3 and OSC 4-6 behave differently when bypassed. On OSC 1-3 the knob turns grey and freezes (can’t be turned/dragged anymore). This is not the case on OSC 4-6, the knob doesn’t look and behave any different when bypassed.

This wouldn’t be an issue per se, if it would be intended to work like that. But everything points towards the knob on OSC 4-6 should behave the same like on OSC 1-3.
Both knobs are set up exactly the same in the layout.xml, so they should behave the same. But they don’t for some reason.

On the screenshot for OSC 4-6 you can also see that it’s set up to utilize a disabled version on almost every knob in the area, like for the “Loop Start” knob. I don’t know where the sense in that is, why should i.e. “Loop Start” have a disabled/bypassed state?

That’s just one example, there’s quite a number of those hidden gems in there :rofl:

Hi again.

No, I’m not that much familiar with the GUI design, but you’re right, this is not working for the Sampler Filter Mix Knob ( tried with sevral different GUI themes here ) and can’t point anything wrong in the XML file like you mentioned. The image resource file name and path are correct.

Not sure if that’s maybe something in the code rather than just the XML and GUI resouces files ???

I will point this out to the developers and SA team, thanks for your feedback :wink:

Yea I think so, too.
Tried several things to fix it (using different files, from different locations etc) but nothing’s working so far. And like you mentioned it’s the same on each on every skin out there. So it seems obvious that it’s happening from within the source code. Could be something simple like a typo in the code.

It was different in the past, in this video from the ANA 2.0 release you can see the knob was acting just like on OSC 1-3 (not sure if timestamp works, it’s at about 4:06)

Probably it broke somewhere around the 2.5 release when the Sampler section was reworked.
The audio processing doesn’t seem to be affected, still I’d call it a bug, if only a graphical.

1 Like

Have you heard anything regarding the Filter Mix knob on the sampler section?

Working on something like this:

btw, the licensing name has been changed by support meanwhile, thanks for that :+1:

Yes, it’s confirmed to be a mistake in the code, that will be fixed in the next release :wink:

This skin looks great BTW ! :+1:

Cool ! :sunglasses:

Nice :+1:
Also means there’s currently no way to fix it on my own, right?

Thanks, still a loooong way to go though…
That’s about the only section that’s somewhere close to how it likely will look in the end.

1 Like

Unfortunately not since it’s in the code :confused:

Likely a dumb question, but I’m no native english speaker so there’s my excuse :stuck_out_tongue:

I’m wondering about the term “series” regarding the filter routing. Is this really correct or shouldn’t it be called “serial”?
On most other Synths they call it “serial” (IF the term appears entirely, quite often symbols are used for that), and “serial” sounds more logical to me than “series”. But again, no native english, are both terms equally appropriate? Is there any difference?


As in… “in series” I.e. one after the other.

Pretty sure it’s more correct than serial


1 Like

Also not a native English speaker myself :sweat_smile:

But yeah, I also think “In Series” is more appropriated.

Looked for it on the web and here’s what I found :

You can use “Serial” or “Processing In Serial” but also “Processing In Series”.

The difference between the 2 relates to the context : if you’re talking about circuits & real components ( series ) or data protocols ( serial ).

i.e :Those LEDs are connected in series” whereas we would say “Serial Wifi, Serial port…etc.

So since ANA is a synth ( even if it’s a virtual one :sweat_smile: ), it makes sense to use Series in relation to real hardware I believe → hence the name A.N.A ( Analog Noise Attack ) :wink: :sunglasses:

1 Like

Thank you both for clarifying :+1:
I’ll stick with “series” then. Really wasn’t sure anymore what is correct there, guess one could use both but like you guys pointed out “series” seems to be “more” correct.

Already brought that back on the settings screen :wink:
(which is still under construction though)

1 Like