Kick 2 couldn’t be opened in Logic X

Hi guys,
I downloaded Kick 2 ver1.1.2 and installed into my Logic, but Logic keeps telling me it can’t be opened in Plug-in Manager and Kick 2 cant be used since then.

System requirements says Mac OS 10.7 or later, so mine should work although it’s 10.11.

Does anyone have a clue?

Hi there @redshikibu

Have you simply try to log out or ( better ) restart your Mac after installing Kick 2 ?

Sometime new plugins won’t appear inside Logic unless you take that step, even if the installation was done, it simply won’t show up inside the Plugin Manager unless you Log Out / Reboot.

If that doesn’t solve your issue, please follow this Manual Uninstall procedure from S.A support page before trying a new installation of Kick 2.

Hope this helps

Thanks for your reply and suggestions.
I’ve tried restarting my Mac after installation followed by uninstalling Kick 2 first with the manual you pasted, but I still get the same issue.
Just attached a screenshot of what I see in the plugin manager from Logic.

Hope this helps you to understand a bit more of what I’m encountering, and help me find a solution.
Really appreciate for your help again.

Hi again @redshikibu

Sorry for late reply :wink: Hmm, that’s a bit strange, especially if you uninstall & reinstall KICK 2 following the previous procedure.

You could try the following things :

  • First be sure to be up to date with Logic, recently was an update to 10.4.7

-Then open Logic, go to Preferences/Plug-In Manager… again, find the Kick2 AU plugin, select it ( highlighted ) and try several times to perform a “Reset & Rescan Selection” using the button at the bottom of the manager.
I’ve seen cases where you have to force this and it just worked.

  • If that doesn’t work, close Logic and go to this folder on your Mac :

Your MacOS HDD/Library/Audio/Plug-Ins/Components and find Kick 2.component Select it and holding Cmd on you keyboard, drag it from the Components folder onto your Desktop. Make sure you haven’t got any more Kick2.component file in this Component folder.

Then download this app ( Permission Reset ) from here Download Permissions Reset by Ohanaware Co., Ltd. or use the one I’m putting here. (2.5 MB)

Unzip it, and you’ll have the app on your desktop, double click to open then just drag & drop Kick2.component from your desktop onto the app, once it appears in there click the “Reset” button confirm action by entering your Admin password if prompted.

Then open Logic once (without the Kick plug-in ), close it.

Select Kick2.component from your desktop and holding Cmd key again, drag it back inside
Your MacOS HDD/Library/Audio/Plug-Ins/Components folder.

Then reopen Logic again and go to the Plug-in Manager, check the status of the plugin.

  • Another thing I’ve sometime seen is prior to installation, depending of what archive app you used to unzip the full Kick2. zip archive downloaded from your Sonic Academy account. So maybe try a fresh download and when it comes to un-ziping the archive, use a different archive manager app. I like to use Keka on MacOS.

If you need to go through the step of re-downloading and try a different app to un-archive the new .zip, then of course follow the uninstall procedure form the previous post before, you want to be sure everything is done correctly in order to avoid files & folder permission issues.

Hope this could help to fix your issue, report it back here :wink:


Any success trying the above ?

Apologies for getting back late.
I’ve tried everything you suggested, even the way to archive the zip file which I downloaded from the scratch off the website, and nothing works…

I’m almost giving up on this issue and thinking the only chance would be to clean install everything.
It’s really a shame, but there maybe no other way to solve this.

Since I’m missing the kick sound, I feel almost pathetic to start producing without a kick :cry:

Really appreciate for your support though. IF there is other methods I can try, I’m more than happy to spend time to try it.
Thank you in advance mate.

Hmm, this is really weird indeed.

Are you on a real MAC or running on a Hackintosh BTW ? It doesn’t makes a difference for running Kick 2, but it would help to know in order to get it working.

Here are next steps you could try :

  • Cleaning your Audio Unit Cache : Note that you will have to rescan all plugins installed on your Mac, that could take some time.

Check both paths : MacOS-HDD/Library/Caches as well as MacOS-HDD/Users/Your User Name/Library/Caches ( so that’s the main MacOS Library and the User Library ( this one could be hidden by default, to learn how to show it refer to this how to show user library on mac - Google Search )

In either those 2 locations or just one you should find a AudioUnitCache folder with the file inside.

You can also refer to the end of this Apple thread Bypass, remove, or rescan Audio Units plug-ins in Logic Pro or MainStage - Apple Support but it might be that this folder is under your User Library and not the main Library.

1- Remove the
2- Remove the AudioUnitCache
3- Clean your Caches by deleting the MacOS-HDD/Library/Caches
4- Reboot your Mac
5- Upon restarting : Start Logic & let it perform a new AU plugins scan. If during this process you have any popup messages like AU Unit Validation Tool ( or similar name ) stopped working, just click on Restart each time.
6- Once all AU plugins have been re-scanned, check inside Logic Plugins Manager is Kick 2 is now showing up properly. Note that at this stage, you should still need to open one instance of Kick 2 in order to complete authorization.

  • If these first steps are not working, then refer to this Apple thread in order to re-install Logic Pro from your Mac ( step N° 9 in the thread with some links ).

  • IF STILL NOT WORKING after this, then my suggestion would be to upgrade to MacOS 10.12 or 10.13 ( Sierra or High Sierra ) - 10.14 Mojave should work too but if you’re running a Hackintosh with an nVidia graphic card then don’t upgrade to Mojave.

And in any case DO NOT UPGRADE TO CATALINA at this time. 10.13 should be fine IMO.

Some other points you could check on a real Mac is to do a PRAM/NVRAM reset : Reset NVRAM on your Mac - Apple Support

Follow those steps in order, starting from AU plugin cache reset & re-scan → MacOS Caches Delete → Then Logic Pro uninstall/reinstall → and finally Upgrading your MacOS version. PRAM/NVRAM reset procedure can be done at any time. Might be the first thing to try in fact.

Take your time to do those steps, nothing complicated if you follow the guidelines :wink:

Waiting for your next update and how things are going, hopefully you should be able to get it working.

Thank you so much for your help!
The last step you taught me finally worked! On my goodness!

You saved my life :slight_smile:

Thanks again.

1 Like


Thank you for the update and very pleased to know that deleting MacOS Audio Plugins caches & re-scanning them all solved your issue.

Time to make some kicks & beats then :smile: Enjoy your Kick 2 plugin ! :wink:

Cheers !