( Solved in v2.0.98 ) : 3D wavetables not loading

Just purchased ANA 2 and am having trouble with 3D wavetables not loading. What happens is, I will choose a 3D wavetable and the name of the wavetable in the OSC section (just under WAVEFORM) just displays “loading” forever without the wavetable actually loading.

I have tested with 3 different DAWs so I do not think the DAW is the issue.

Also, reading 2 threads in this support forum (this and this), I have uninstalled + deleted data folders, then re-installed the newest version of ANA 2 but the issue persists.

I have checked all of the factory 3D wavetables and will list the few that did load (in alphabetical order):

3D Wavetables

  • Acid 128
  • Flame
  • FM Grit 1
  • FM Saw Fuzz
  • FM Squelch Growel 1
  • FM Squelch Growel 2
  • Load of Bells
  • VFG 1, 2, and 3

3D Analog wav

  • DM12 Tone mod

3D Digital

  • Jippy Organ
  • Mount-City

All other 3D wavetables will not load. I have tested a few of the wavetables that did not load in ANA 2 by dragging them onto Vital, and all of them did work. I could morph though the frames just fine, so I think there are no corrupt files or anything.

Any assistance will be appreciated.

My environment:
WIndows 10 Home 64 bit (update 20H2)
CPU - Core i5 8265U
RAM - 16 GB
Drive - SSD
DAW - Ableton Live Intro 11.0.2, FL Studio 20.8.3, Bitwig 8-track 3.3.7
ANA 2 version - 2.0.97

Hey there @Junity

Thanks for reporting this and the details :thumbsup:

I will try to replicate this on Win 10 20H2 on my end & update this thread with the results.

Just 2 more questions :

  • Is this happening only with VST 2 or VST 3 or both of them ?
  • Where you having multiple instances of ANA 2 in the DAWs or only one ?

Thanks :wink:


I’m not able to reproduce this under Windows 10 20H2 ( Up to date as well except that I’m running Win 10 Pro ).

Tested with Ableton Live Suite 10.10.35, Bitwig 3.3.7, FL Studio 20 latest ( demo ) and I have no problem loading wavetables from ANA 2 browser. Working fine here with both VST2 & VST 3, also tried with 2 instances loaded inside the DAW and it was still working.

  • We are both talking “Factory” presets here, I assume, right ?

Could you please check your folder structure inside ANA 2 GUI, would you have any sub-folder or custom folder or something different than the pic below on your end ?

i.e → you mentioned 3D Analog wav in your initial post, was this just when writing it here or is your folder actually named like this inside the browser ?

  • Also, even if you might have done it already after reading the other threads, I would suggest to try a manual uninstall / install as explained here on the support page but before going into this could you just try the following :

→ With all DAWs & ANA 2 instances CLOSED, from Win Explorer go to :

C:/Users/Your_User_Name/AppData/Roaming/Sonic Academy/ANA 2

you’ll find a ANA 2.settings file, DELETE it and restart your DAW and launch a new instance of ANA 2 to see if it changing anything.

Hello @Tekalight

Thanks for your assistance.
I will be testing on FL Studio from here on out since that is one we can have version unity.

  • This is happenning on both VST2 and VST3 versions.

  • I originally tested with only one instance, but the issue seems to be the same with 2 and 3 instances also.

  • As a side effect, I just experienced my first FL Studio crash when loading 3 instances of ANA 2, but was able to load 3 ANA 2s just fine the second attempt. Don’t know what happenned (the FL project was blank apart from the 3 ANA 2s).

  • I am not testing with any presets, I init the synth and select a wavetable for OSC 1. I have yet to create a preset or import my own wavetables.

  • The folder structure is the same as the screenshot you have provied (I have completely re-installed ANA 2). “wav” was just a typo on my part, sorry.

  • I have indeed deleted the data in the hidden AppData directory before re-installing.

Also, upon inspection of the wavetable directory with Windows File Explorer, I have notieced a similarity with the wavetables in question. The ones that will load are smaller in file size.

In 3D Analog directory:

  • DM12 Tone Mod.wav (the only one that will load) is 1,025 KB.
  • All others are 2,049 KB.

In 3D Digital directory:

  • Jippy Organ.wav and Mount-City.wav are both 1,025 KB (these will load).
  • All others are 2,049 KB.

In 3D Wavetables directory:

  • VFG 1.wav is 1,494 KB (the largest wavetable in this directory that will load).
  • ClassGtr.wav is 1,609 KB and will NOT load. Other wavetables that do NOT load are larger than this.

I tried adjusting the buffer size in FL Studio to see if that has any effect, but it did not.

1 Like

Hi again @Junity

Thanks or the update :wink:

Yes, there’s an issue on Windows when using multiple instances of ANA 2 and going back & forth between them and then trying to reopen the plugin GUI that was reported here

Number of ANA 2 instances opened before the problem occurs may vary depending on your DAW.

I doubt it will make a difference but since this time it will “post-installation” could you try to delete your ANA 2.settings file located in C:/Users/Your_User_Name/AppData/Roaming/Sonic Academy/ANA 2

Do this with your DAW closed and then reopen it and launch a new instance of ANA 2 to see if it makes any change.

I will do some more testing in FL on Windows this morning following your scenario and will update if I found any issue. Meanwhile I’m also pointing this to the S.A team.

FWD → @bryan_spence @phil_johnston

Thanks for the advise.

Deleted the ANA2.settings file with my DAW closed, but did not change anything as you suspected. The same 3D wavetables would load (the small files), but others will not.

While going through factory presets, I found a way to load one specific 3D wavetable.

  1. Choose factory preset Badass in the Bass category.
  2. ANA 2 loads the 3D wavetable Garage Bass in OSC 1 and OSC 3, and a 2D wavetable SynBuzz in OSC 2.
  3. Change OSC 2’s wavetable to Garage Bass.
  4. Now, I can Init ANA 2 and load Garage Bass into OSC 1/2/3 or add a new instance of ANA 2 and will be able to load Garage Bass as well.

If I skip step 3, I cannot load Garage Bass.

Even if I take the above steps, other 3D wavetables with larger file sizes will not load, but I suspect I can if I find the right preset and follow the same steps.

Not sure why loading the wavetable directly is any different from loading it as a part of a preset, but hope this information helps to pinpoint the issue.


1 Like

Hello again…

So, I’ve been trying to replicate this again following your scenario but I don’t have issues with loading OSC wavetables files.

Screened a video to show you what I did.

To sum it up :

  • Open FL Studio Demo ( it’s the latest FL20 up to date version )
  • Open ANA 2 VST 2 → Init Preset → loading wavetables → same operation again from the different folders.
  • Open ANA 2 VST 3 and did the same things

No problem to load wavetables to OSC 1 on my end, even with the 2 instances.

So that’s a rather odd behavior on your end, especially if you followed the manual uninstall procedure before, might worth it to give it a new try though, this time making extra sure to remove all files and I also suggest to run CCleaner to clean your registry + files and then reboot your computer and download a fresh v2.0.97 installer from your account to avoid any possible corrupted archive. I know not everyone is positive about it but I do use the free version of CCleaner all the time and perform exhaustive registry cleans on my PC without any issues, just make sure to deny any software install when running their installer if you don’t alreeady have it installed. For archives, I rely on Winrar 64bit, there’s a free version as well.

Here’s the video Loading OSC 3dWavetables ANA2 FL Win - YouTube

For S.A staff :

@bryan_spence this one is puzzling me, would you like the user to open a support ticket ? If a new clean install doesn’t solve the problem maybe a remote session with you & the user could help, it’s pretty limiting not being able to load wavetables to OSC.

I’ve tried manually deleting and re-installing ANA 2 the second time, but of course the situation is the same (most 3D wavetables will not load). Apprecitate the advise but I will not install or use CCleaner (I understand it has never given you issues).

Also, a remote desktop software will not be an option either, so I guess I have exhausted all possible fixes for now.

Will wait on any new information from the dev team, but I would like to ask of S.A.'s refund policy (if any). It is my fault for not thoroughly demo-ing the software before purchase, and I will make it a habit to test with multiple instances of a plugin in the future (the “multiple instances crashing my DAW” is acutally more troublesome than the 3D wavetable thing).

I ask now because I don’t think it is fair to request a refund months after the purchase. So, does S.A. offer refunds? And if so, how would one proceed?


Yeah of course if you are not happy you can have a full refund.

I’m going to see if I can get the previous version uploaded to accounts for anyone who wants to roll back to a previous version until we track down these issues.


At this point I also think that rolling back to the previous version is worth trying to really see if ANA 2 is something for you and works fine with your own setup. Maybe @bryan_spence could email you a link to the previous v2.0.94 installer ?

However if you decide to go for a refund, send an email to mailto:customerservice@sonicacademy.com and point them to this thread on the forum.

ANA 2 is a very great soft-synth IMO, the devs will fix those issues with the latest version in time :wink:

1 Like

Thanks for your replies @Tekalight and @phil_johnston

Looking forward to testing a version roll back or update. Like you say @Tekalight, ANA 2 seems like a great synth to get to know. But I can also understand the technical difficulties in the software world. Our environments differ so much.

Please take care.

1 Like

Hey there @Junity

Following up on this issue, have you tried to install latest v2.0.98 yet and check if it’s properly working for you ?

Thanks to let us know :wink:

Hello @Tekalight

I have installed ver 2.0.98.

3D wavetables: can confirmed this issue fixed.
Multiple instances crashing FL Studio: this seems to be fixed too. Though the DAW does not crash, it sometimes still takes a long time for one of the instance’s GUI to load. But other times near instant. Not sure the cause.

1 Like

Thanks for the feedback :wink:

I’ll be honest FL Studio is still a mystery to me, basically just using the demo for testing out things on my end :smile: but from what I know it’s using a wrapper and a kind of “sand box” cache system to load plugins and prevent the full DAW crash, there’s a similar thing with Bitwig Studio and I’ve noticed that plugins take more time to load when using this feature.